Support » Fixing WordPress » Gallery option missing from media

  • I’m using the Chateau Theme featured on WordPress. I’m trying to put a photo gallery on a page. The Gallery option does not show up when I click on the insert media option.
    This is running on a self hosted site, but I’m not sure if you can see it because its set up to look at an index page while i finish designing the WP theme. Any ideas?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Have you uploaded more than 1 image to your Page or Post?

    Yes I uploaded several and worked on alot of issues. I did find another post that I think is related and very interesting. You can find it here.
    After reading it. I uninstalled the JetPack plugin. Still no gallery, but I was able to install a plugin called SlideShow, not the answer to the problem , it works but its clunky as in I have to add all the media to the post/page then it gives me a gallery then I have to edit the gallery and add [slideshow] to the bottom of the HTML code, then I have to go back and delete all the photos, then walla I have a very nice looking slide show. Alot of work, but right now my customer is happy.
    The short of it is it still does not work correctly. If you read the other post its happening in many themes, seems like WordPress has some work to do, and not paying attention to the problem.

    It’s not a WordPress bug. The Gallery is working perfectly well on thousands of other sites – including about 12 that I look after or own.

    Have you uploaded more than 1 image to any particular Page or Post via the Add Image option in Edit Post or Edit Page?

    Yes I’ve done exactly that – did you read the other thread I pointed to. I have other sites as well that its working on – seems to hit some themes and not others.
    You’re pretty strong about it not being a WordPress bug. How are you so sure?

    100% sure.

    How can that be? And if so then tell me how to fix the problem.

    How can that be?

    Because it’s working perfectly well on the vast majority of sites. Whatever this is, it is specific to this site which means it’s a server, plugin or theme issue – not a WordPress one. Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    Thanks for those actions – some I have not tried. I did uninstall Jetpack – and that did help a bit. I will try your suggestions.

    But I still have to say that I am not the only one having the problem and not on the same hosting company, just because you think its working perfectly well on a vast majority of sites – doesn’t mean it is so, alot of them may not even be using the gallery….just saying.

    I’ll post my results of your suggestions

    I cant Run the Jetpack plugin – oher than that everything is working ok.
    Thank you. Do you know of a good reliabe plugin to se in place of Jepack for site stats?

    WordPress 3.31. Fresh install. No gallery options for me either. Further, I cannot drag order the images in the gallery tab.

    I believe that this is some sort of server issue with WP but have no idea how to solve it. I have several sites that this works with and several that don’t.

    I would be happy to try something if I had any idea what.

    Are you trying to insert images that are already in your media library? Does the gallery option appear if you try and upload new images? I have the issue where there is no gallery option for inserting images already uploaded to the media library. If I upload new images, the gallery option appears. Useless!

    I have the exact same problem and it must be a very big WP bug, because I am about to create a shop site, and have already uploaded all the fotos…
    Can anybody come up with a solution asap?
    Thanks in advance.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Gallery option missing from media’ is closed to new replies.