Support » Plugin: WP Gallery Custom Links » Gallery not showing in sidebar on startpage

  • Resolved webkreator

    (@webkreator)


    if you encounter the error that the gallery not showing at your homepage with the newest (4.9.3/4.9.4) wordpress version,
    edit the file /wp-content/plugins/wp-gallery-custom-links/wp-gallery-custom-links.php

    and change near line 167

    		} else {
    			return ' ';
    		}

    to

    		} else {
    			//return ' ';
    		}
    
    • This topic was modified 3 years ago by webkreator.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter webkreator

    (@webkreator)

    just an information for other users

    probablepossible

    (@probablepossible)

    To be more specific, webkreator’s fix works for when your gallery shows fine on a page but a gallery widget shows this message;

    
    Warning: explode() expects parameter 2 to be string, array given in .../wp-content/plugins/wp-gallery-custom-links/wp-gallery-custom-links.php on line 205
    
    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in .../wp-content/plugins/wp-gallery-custom-links/wp-gallery-custom-links.php on line 205
    
    Warning: explode() expects parameter 2 to be string, array given in /home/content/79/11417579/html/wp-content/plugins/wp-gallery-custom-links/wp-gallery-custom-links.php on line 216
    
    Warning: array_merge() [function.array-merge]: Argument #1 is not an array in..../wp-content/plugins/wp-gallery-custom-links/wp-gallery-custom-links.php on line 216
    
    Warning: array_unique() expects parameter 1 to be array, null given in .../wp-content/plugins/wp-gallery-custom-links/wp-gallery-custom-links.php on line 220
    
    Warning: Invalid argument supplied for foreach() in.../wp-content/plugins/wp-gallery-custom-links/wp-gallery-custom-links.php on line 222

    Thank you, you saved my bacon 🙂

    • This reply was modified 3 years ago by .

    Hello,
    thanks so much for helping out! I tried the solution but it didn’t work for me – same warnings still pop up. Could you advise what to do?

    Many thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Gallery not showing in sidebar on startpage’ is closed to new replies.