WordPress.org

Forums

Jetpack by WordPress.com
[resolved] Gallery Not Found (11 posts)

  1. Neil Haslewood
    Member
    Posted 1 year ago #

    Hi

    After updating to 2.6 my website no longer shows my Gallery at the top of my homepage. The error message is "Gallery not found. Please check your settings".

    If I un-install Jetpack then the problem disappears and the Gallery Slideshow works again. If I reinstall Jetpack I am back to the same problem.

    The problem can be seen at http://www.peakandfellwalking.co.uk/

    Can you please help.

    Regards

    Neil

    http://wordpress.org/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you let me know how you usually add a gallery to this section of the page, and if it's managed by your theme or an external plugin?

    Thanks!

  3. Neil Haslewood
    Member
    Posted 1 year ago #

    Hi Jeremy

    It is a Slideshow of 4 images. The standard Gallery is used for images but my theme is used for the Slideshow. My theme is provided by Dottoro.

    I hope this helps.

    Regards

    Neil

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks.

    Your theme is a premium theme, so I cannot download it to find out more about how the slideshow is built. Does it take Featured Images from 4 specific posts, that you've tagged or added to a specific category maybe? Could you also let me know how it is inserted into the page? Do you use a shortcode to insert that slideshow, and if so, could you post that shortcode here?

  5. Neil Haslewood
    Member
    Posted 1 year ago #

    Hi Jeremy

    Ok I will try and explain. The Slideshow is shown in a Sub Header. This is defined in Templates-Subheaders. The code for the "Home" subheader is ... [slideshow name='Home' pagination_align='right' pagination_type='images' pagination_button_width='80' pagination_button_height='30'/]

    The images are just stored in the wordpress media gallery.

    The "Home" Slideshow is defined in Slideshows where each slide is added to the slideshow as well as dimensions, scale, autoplay and pagination.

    There are no tags or categories involved and does not take featured images from specific posts.

    Thank you for your help.

    Regards
    Neil

  6. Neil Haslewood
    Member
    Posted 1 year ago #

    Hi Jeremy

    I have worked out that it is not my theme that is causing the problem. It is something to do with NextGen and Jetpack. If I deactivate either one of them the problem is resolved. So Jetpack deactivated with NextGen activated is ok and also Jetpack activated with NextGen deactivated is ok. However if both of them are activated then the gallery slideshow disappears.

    What is my next step? Thank you for your help.

    Regards
    Neil

  7. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Try to disable Jetpack's slideshow shortcode by adding the following code to your theme's functions.php or to a functionality plugin:

    function jeherve_remove_slideshow( $shortcodes ) {
        $jetpack_shortcodes_dir = WP_CONTENT_DIR . '/plugins/jetpack/modules/shortcodes/';
    
        $shortcodes_to_unload = array( 'slideshow.php' );
    
        foreach ( $shortcodes_to_unload as $shortcode ) {
            if ( $key = array_search( $jetpack_shortcodes_dir . $shortcode, $shortcodes ) ) {
                unset( $shortcodes[$key] );
            }
        }
    
        return $shortcodes;
    }
    add_filter( 'jetpack_shortcodes_to_include', 'jeherve_remove_slideshow' );

    Let me know if it helps.

  8. Neil Haslewood
    Member
    Posted 1 year ago #

    Hi Jeremy

    Unfortunately it had no effect. I have removed the code form my themes functions.php for now until we find a solution.

    Regards
    Neil

  9. Neil Haslewood
    Member
    Posted 1 year ago #

    Hi Jeremy

    I have just updated to the latest version of Jetpack (2.6.1) and this has now solved my issue.

    Thank you

    Regards
    Neil

  10. Baumoos
    Member
    Posted 1 year ago #

    Hello,

    I got problems with slideshow gallery after I've updatet to v 1.2.3.2. (Wp 3.7.1). Error "gallery not found, check your settings"

    I solved it by deactivating plugin "NextGEN gallery by Photocrati". It seems, there is a conflict between both.

    kind regards
    Alois

  11. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @Baumoos Could you update to Jetpack 2.6.1, as Neil suggested above?

    If that doesn't help, could you please start your own thread, as per the Forum Welcome?
    http://wordpress.org/support/plugin/jetpack#postform

    It could also be useful if you gave us more details about your issue, like a link to your gallery page.

    Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags