Support » Plugin: Best Image Gallery & Responsive Photo Gallery - FooGallery » Gallery is loeaded but images are not showing

  • Resolved smit_ralph

    (@smit_ralph)


    Hi, I use your wonderful plugin on several websites, some with free, some with the payed version, and I am very happy with it. Now, however, I have a strange problem (which is probably javascript related due to the way the age is built…).

    In my galleries, my images are not showing. They are loaded and they will show in FooBox when they are clicked.

    When I insepct it I can see a link element with the correct “href” attribute, and an img element with a “data-img-fg” attribute, but the “src” attribute is missing.

    I hope you can help, thx!!
    Ralph

    • This topic was modified 4 months, 2 weeks ago by smit_ralph.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author bradvin

    (@bradvin)

    Hi @smit_ralph

    I had a look at your page, and it seems that the foogallery javascript is not being included on the page. It seems that the gallery is being loaded by an ajax call, which means that the page is not enqueuing the script on the page.

    Can you try to add this custom code to your theme’s function.php file:

    
    function force_load_foogallery($hook) {
        foogallery_enqueue_core_gallery_template_script();
        foogallery_enqueue_core_gallery_template_style();
    }
    add_action('wp_enqueue_scripts', 'force_load_foogallery');
    
    Thread Starter smit_ralph

    (@smit_ralph)

    Thx for your quick reply. What you describe is exactly the problem, because of the ajazx call. I have tried your solution, and the gallery is loaded now (great!), but only some of the images show, some of the time. You can check this yourself by clicking on different project on the left side of the page.

    I tried moving this snippet to the start of my child theme’s functions.php file (instead of the end), but that has no effect. I do think it’s something in the order of execution?

    Any ideas? Yhx!

    Plugin Author bradvin

    (@bradvin)

    Hey @smit_ralph

    I can see what you mean.

    @steveush, please have a look at the page. Click on the first image top left, then the right pane loads. If you scroll down to the gallery, you will see that it does not load, almost like it thinks it has not scrolled into view

    Thread Starter smit_ralph

    (@smit_ralph)

    Advancing your collegue’s reply, would this mean that there is a lazy loading kind of fucntion we could disable?

    Plugin Author bradvin

    (@bradvin)

    There is a setting to disable lazy loading under the advanced tab, but I am not sure that will work. Test is out and let me know

    Thread Starter smit_ralph

    (@smit_ralph)

    Well, that does seem to do the trick…..

    Plugin Author bradvin

    (@bradvin)

    Ok great.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.