Support » Plugin: Gallery by BestWebSoft » Gallery images showing as vertical in posts

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hey, I just fixed this problem on my friends site after he updated the plugin. This is a bit of a hack, but worked for me.
    First off, go to the Gallery settings page, and set ‘Number of images in row’ to 1.

    Then, put the below rules in your CSS:

    .gallery.clearfix{
    width:100%;
    }
    .gllr_image_row{
    float:left;
    clear:none;
    }

    This makes the wrapper for the gallery fill all available space, and then makes all your rows of one image float left of each other i.e. in one long row, that breaks over multiple lines.

    I then found there were a bunch of line breaks and empty paragraphs messing up my layout – this is why your thumbnails aren’t inside the bordered boxes – so I added the below in the theme files.

    Go to ‘gallery-plugin/js/frontend_scripts.js’ and add this at the very bottom before the closing brace and bracket.

    $( document ).ready(function() {
        $('.gallery_box_single').find('br').remove();
    	$( 'p:empty' ).remove();
    });

    Bear in mind that that change will be overwritten next time you update the plugin, so adding it in a custom script might be safer. I added it here so I knew it would be on every page that the plugin is in action. I’m not expert but I hope this helps.

    Plugin Author bestwebsoft

    (@bestwebsoft)

    Hi,

    Our plugin functionality doesn’t provide creating of additional html-tags (</br>, empty <p>). It seems like they are generated by your theme. So if described changes have been made in the plugin files, please comment them for a while and try the following:

    1) Please try activating a standard WP theme for a while (2014, 2015) and check if the problem remains.
    2) Please try deactivating all of your plugins except Gallery by BestWebSoft and also check if the problem is still present. If it is not, please activate the plugins one-by-one, meanwhile checking, after which plugin activation the problem appears again.
    3) Please let us know about the results.

    Best Regards,
    BestWebSoft Support Team

    Plugin Author bestwebsoft

    (@bestwebsoft)

    Hi,

    Since there is no reply from you, we consider this topic as resolved. We hope you’ve found the solution. If you have any questions, please feel free to contact us via our Help Center – http://support.bestwebsoft.com/.

    Sincerely,
    BestWebSoft Support Team

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Gallery images showing as vertical in posts’ is closed to new replies.