Support » Plugin: WordPress Responsive Gallery Plugin - FooGallery » Gallery Images Not Indexing By Search Engines

  • Resolved GorselDersler

    (@gorseldersler)


    Hi,

    There are 30 galleries generated with foo-gallery plugin in my site. I also using Yoast SEO plugin. When I check Google and also Yandex, I see ZERO image! No image indexing.. Why FooGallery Images not indexing by Search Engines please?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support phillcoxon

    (@phillcoxon)

    @bradvin – are you able to respond to this request regarding indexing of images please?

    No support for this plugin?

    Plugin Author bradvin

    (@bradvin)

    @gorseldersler apologies for the delay – I was looking at the code to see what the problem could be.

    It looks like images are added to the sitemap when it detects the foogallery shortcode only. I have updated the code to also take into account elementor content and also the block from gutenberg.

    How have you added your galleries to the page?

    @bradvin Thanks for response. Added galleries by using “Add FooGallery” button in editor.

    https://i.imgur.com/WlEXJqk.jpg

    Plugin Author bradvin

    (@bradvin)

    That should be fine then, because that adds a shortcode.

    Can you link to a page on your site with a gallery, and then I can look at your sitemap?

    @bradvin Thank you. (+18) Pornopics.Net

    Plugin Author bradvin

    (@bradvin)

    I had a look at your sitemap for a particular page and compared it to the images within the foogallery and they are within the sitemap, so everything is working as expected from a sitemap point of view.

    I am not sure why they are not being indexed by Google. It could be that they are taking some time to be indexed, or you have some other reason that they are being blocked from being indexed

    opc121177

    (@opc121177)

    Hi there,

    Could somebody please help me, i built this site: https://myfunphotobooth.com/croydon-photo-booth-hire.html some years ago and it also appears that the images have never been indexed by Google when used within Foogallery.
    I have recently started using a CDN but the problem existed long before then. Any ideas?

    Warmest regards

    Paul

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.