Support » Fixing WordPress » Gallery image link to attachment page broken after update.

  • Resolved Ken Duret

    (@kenduret)


    I had all my gallery images linked to the attachment page using the default ‘image links to attachment page’ in the media uploader.

    When I upgraded to WP 3.1.1 all the ‘links to attachment’ links are gone and no longer work. I tried creating a new gallery and checked ‘images link to attachment page’ and none of the images actually link to the attachment page and instead link to the image file.

    I do have an attachment.php in my theme but all the gallery images actually link to the image file and not the attachment page. I can’t figure out why or how to fix. Any ideas?

    Here’s an example: http://kenduret.com/honey-bees/ See ‘All images from this series’ at the bottom of the post.

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • esmi

    (@esmi)

    Forum Moderator

    There isn’t an “image links to attachment page” in WordPress by default. There are just 3 options: File Url, Post Url or None. And the default gallery works by displaying all images uploaded via Add Media whilst working on that page.

    After uploading images for the page via the media uploader I click ‘gallery’ and at the bottom of that page I have ‘Link thumbnails to:’ with radio buttons that say ‘Image File’ or ‘Attachment Page’.

    Here’s a screenshot of the feature: http://kenduret.com/wp-content/uploads/2011/04/gallery.jpg

    I’ve used this many times in the past and now after the upgrade to 3.1.1 it’s broken.

    Solved. This was a conflict with the Lightview Plus plugin.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Gallery image link to attachment page broken after update.’ is closed to new replies.