Support » Plugin: User Submitted Posts » gallery doesn’t display

  • Resolved horizon89

    (@horizon89)


    Hi,

    First, very good plugin ! Great job 😉

    I write to you cause I have a little problem to display a gallery of the users’ posts…
    I use the shortcode [usp_gallery] but it doesn’t work…

    How to fixe that ?

    Thanks in advance for your help !

    Angélique

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Jeff Starr

    (@specialk)

    Glad to help. I’m not sure what may be happening in this case, but it sounds like something is interfering with normal functionality. If you want to determine the cause of the issue, you can do some basic troubleshooting of your theme and plugins. Troubleshooting will let you know if the issue is theme-related or plugin-related. Let me know if I can provide any further infos, glad to help.

    Hi Jeff Starr,

    Thank you for your answer !

    Okay I’m gonna try to desactive my theme and plugins, and I’ll keep you informed 😉

    Angélique

    I’ve desactived my theme and all my plugins, it still doesn’t work 🙁
    I also tried different settings of the plugin, no result…

    On my page, I use the shortcodes :
    [user-submitted-posts]
    [usp_gallery]

    Is it the fact that the both shortcodes are on the same page ?

    If I can’t solve the issue, I’ll use a element WPBakery Page Builder to display the category’s posts.

    Thanks for your help !
    Angélique

    Plugin Author Jeff Starr

    (@specialk)

    It could be that you are using both shortcodes on the same page, but it’s not something that I have experienced before (definitely worth checking though).

    Another thing to try, so you can see how the shortcodes work in general. Try setting up a quick 5-minute WP install. Leave everything at defaults (settings, plugins, and theme). Then install only USP and try again. After verifying default plugin functionality, you can begin adding your other plugins/theme until the problem returns, and then will know where there is any conflict.

    Okay, I’m gonna do the test 😉

    I’ve just done to test and it doesn’t work ! 🙁

    http://www.horizon-icaunais.com/wordpress/

    I’ve posted 5 articles and they aren’t displayed under the form…

    I’m stuck :/

    Plugin Author Jeff Starr

    (@specialk)

    Thanks for testing this and providing feedback. I also have tested this on default WP and can confirm that it’s a bug. Will definitely try to get this fixed up for the next plugin update.

    Hi Jeff,

    You’re welcome 😉

    Good luck with the work to the whole team !

    Angélique

    Plugin Author Jeff Starr

    (@specialk)

    Hi Angélique,

    Just to follow up with this, the [usp_gallery] “Displays a gallery of all submitted images for the current post.” So that means it only works on the actual submitted post. If you add the shortcode to any other location (like some page), there are no attached images so there is nothing to display. Single posts only. You can find more details in the plugin documentation:

    https://wordpress.org/plugins/user-submitted-posts/#installation

    Let me know if any questions about this, glad to help however possible.

    Hi Jeff,

    Okay, thanks for the clarification and your help 😉

    Angélique

    I can’t get it to display either. Has this been fixed?

    Plugin Author Jeff Starr

    (@specialk)

    @npoutdoors it was never broken, just incorrect usage. Check out my previous reply on this thread:

    https://wordpress.org/support/topic/gallery-doesnt-display-3/#post-11319736

    ahhh makes sense, I read that too and didn’t understand it at first. Thank you!

    So there’s no way to display all the submitted post photos on one page?

    That’s what I hoped that shortcode would do also.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘gallery doesn’t display’ is closed to new replies.