Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Gallery Conflict with Yoast

  • Resolved 5starcruises

    (@5starcruises)


    HI i have just installed to the new version of Yoast which has a great feature to highlight certain text that need to be looked at. It wasn’t working and having spoken to Yoast support team they say there is a conflict. Its with NextGen unfortunately. I would have to keep deactivating Nextgen whist the site is live to see the text which needs changing. I am running all the latest versions of the plugins.

    Any Help gratefully recieved.

    http://www.buckapartyvenues.com.au

    Thanks

    Danny

    https://wordpress.org/plugins/nextgen-gallery/

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author photocrati

    (@photocrati)

    @5starcruises – Although we do have a very small change to our code relevant to Yoast we have not had any recent reports of problems such as what you are describing.

    Which specific version of Yoast are you referring to?

    – Cais.

    Thread Starter 5starcruises

    (@5starcruises)

    Hi

    Its the latest version 3.3.1 I have looked on two websites i have with different themes and still the same issue.

    https://yoast.com/yoast-seo-3-3/ the analysis doesnt show up when NG is active.

    Thanks

    Danny

    Hi there – I think I am having the same issue.

    I have NextGEN Gallery 2.1.43 and NextGEN Plus by Photocrati 1.3.14, and have just updated to 3.3.1 Yoast.

    I use the NextGEN Pro Thumbnail Grid on a bunch of my portfolio pages. The galleries are all still present, they are showing up on the correct pages etc, but the slideshow function has suddenly stopped working, so when I click on any of the thumbnails it just opens the image in a separate web page, instead of uploading the scrolling slideshow.

    I’ve tried deactivating and reactivating all my plugins but that is not doing the trick. The website currently looks really really bad and my business is very image-reliant, would really appreciate an urgent response please.

    Website: http://www.ellymacdonalddesign.com
    Example portfolio page: http://www.ellymacdonalddesign.com/skyline-condo-singapore/

    Thanks in advance,
    Elly

    UPDATE: Also I just discovered that an entire page is not working:
    http://www.ellymacdonalddesign.com/press/

    I have the NextGEN Pro Horizontal Filmstrip on here, but it’s just not showing up. This is damaging my business, please could you respond urgently?

    Thanks
    Elly

    I have the exact problem as the first poster. The content analyzer will not highlight the text in the post body, unless I deactivate the NG plugin.

    I have deactivated all other plug-ins and even tried the Twenty-sixteen Theme…No Luck

    Any help would be appreciated.

    Thanks

    Plugin Author photocrati

    (@photocrati)

    @ellyhails – Please contact our support team directly with any questions or concerns for NextGEN Pro via your member’s area at https://imagely.com/account/

    Thanks!

    – Cais.

    Plugin Author photocrati

    (@photocrati)

    @badknees – Please update to the latest release of NextGEN Gallery published this morning. If this does not resolve the issue, please start your own topic so we can try to help you with your specific issue on your specific site.

    See http://codex.wordpress.org/Forum_Welcome#Where_To_Post

    Thanks!

    – Cais.

    I am getting an error on localhost with ONLY NextGEN Gallery Version 2.1.46 and Yoast SEO version 3.3.2 activated. It is definitely a conflict from NextGEN Gallery.

    Here is the warning: Notice: wpseo_pre_analysis_post_content filter/action is deprecated since version WPSEO 3.0! Use javascript instead. in C:\Projects\StephensAndSmith\StephensAndSmith\wp-includes\functions.php on line 3658

    It does not happen when I deactivate NextGEN Gallery. If I roll back to NextGEN Gallery Version 2.1.43 the error goes away.

    This error only appears in the Admin Panel. I have WP_DEBUG and WP_DEBUG_LOG both set to True.

    Any help would be appreciated.

    Thanks!

    -Ramona

    c.walter

    (@cwalterpas-solutionsch)

    I have the exact same problem as RamonaEid…

    Plugin Author photocrati

    (@photocrati)

    @ramonaeid & cwalterpas-solutionsch – Although the issue you are seeing only appears to be triggered with NextGEN Gallery, I would still look to WPSEO as the one to solve the deprecated notice.

    Thanks!

    – Cais.

    Thanks Cais, will do.

    Plugin Author photocrati

    (@photocrati)

    @ellyhails – Thanks!

    – Cais.

    NextGEN is using a filter, wpseo_pre_analysis_post_content, on line 118 of module.attach_to_post.php, which was deprecated in version 3.0 of WPSEO, which was released seven months ago.

    How is WPSEO going to fix you not updating your plugin?

    Plugin Author photocrati

    (@photocrati)

    @billsmithem – Thanks for pointing out there are deprecated hooks in WPSEO … based on its code we should be seeing messages to the effect they are deprecated and we are not. They may need to look into that themselves though.

    – Cais.

    All you have to do is put WP into debug mode and they’ll be displayed.

    In wp-config.php: define(‘WP_DEBUG’, true);

    Shouldn’t be developing code without it turned on.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Gallery Conflict with Yoast’ is closed to new replies.