Support » How-To and Troubleshooting » [Resolved] Gallery button is missing when uploading images

[Resolved] Gallery button is missing when uploading images

Viewing 13 replies - 1 through 13 (of 13 total)
  • esmi


    Forum Moderator

    Have you tried:

    – disabling Google Gears if you have that running/installed within Firefox.

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-related problems.

    renaming the plugins folder via FTP

    – reading http://wordpress.org/support/topic/279132

    Same issue here – seems that noone has found a fix.

    only current workaround i’ve found is that if you hit ‘save as draft’ first, then upload your images, the gallery link should appear afterwards.

    Some issue here… no Gallery button showing up at all.

    @solarcrash: Doesn’t work for me as well. The strangest thing ist: I created a gallery before, but now the button doesn’t show up any more. I’ve read this so often on the web, is this really no existing bug?

    If I’m not mistaken, the gallery tab first appears when there are image files attached to the post. The media library shows if a file is attached to a post, right between author and comments. AND, as solarcrash writes, the post also has to be saved as a draft first.

    1. save your new post as a draft
    2. add an image with the upload/insert inside the post (not directly in the media library) and fresh from computer
    3. press “save all changes”

    And the gallery tab should appear then. This does the trick on the site I’m working on at the moment.



    Hi all. I have finally figured it out. The way to get your gallery tab to appear you first should name your post (this can be changed later if you want)next Click on the save draft button. Now when you go to select image files and then save them (do not insert into post at this time). You should now have a gallery tab at the top of the page. From this point you can either add more photos/edit photos or insert the entire gallery into your post. I make a point of clicking on the button labeled “save changes” often after every change I make.

    I hope this helps everyone out. I know it drove me crazy for a long time.

    Wow. I’m glad I wasn’t the only one totally stumped by this incredibly convoluted process.

    Thank you, super sleuths! This worked for me!

    I can’t believe this hasn’t been fixed with an update yet.

    Does anyone know a fix for it?


    Moderator James Huff


    markthedoc, this topic has a solution in it already. Look two and three posts above yours.

    Is there no actual ‘fix’ for this though?

    That’s just a work around.

    Moderator James Huff


    I guess so. I’ve never had a problem with it. Saving as a draft is the one thing that I’ve never had to do, but all the rest is normal functionality.

    Does anyone know if this is fixed in WordPress 3?

    I had a quick look and this does seem to be fixed in WP3.

    Hooray! 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] Gallery button is missing when uploading images’ is closed to new replies.