Support » Theme: GeneratePress » Gallery-block link to large-size images instead of full-size

  • Ajkub

    (@pudliszewski)


    Hi!

    I’m actually rebuilding my site with Gutenberg. All things looks nice except gallery.

    In gallery block all small thumbs links to large-size of images, when I want link to full-size of images. I observed that the problem occur when inserting a block with a new gallery (wp do it automatically?). How can I fix it? I don’t see any option for it.

    Before questions. I use lightbox plugin, which I set up to link to full-images, but it does not change anything. So it’s not a plugin problem (I checked it also by completely deactivated this plugin).

    Please help guys!

    I hope You understand me. I’m not fluent in english.

    • This topic was modified 2 years, 5 months ago by Ajkub. Reason: put link to post with gallery for better example

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Theme Author Tom

    (@edge22)

    Hi there,

    I just gave this a try with the gallery Gutenberg block, and my images are opening the full image – not the large size image.

    I wonder if it’s another plugin causing it to open the large size?

    If not, can you deactivate the lightbox plugin for a moment so I can take a look?

    Let me know 🙂

    Thread Starter Ajkub

    (@pudliszewski)

    Hi Tom!
    Thanks for fast reply.

    So I made some tests.

    When I create gallery block and set option “link to” to media file, gallery shows large-size images.
    When I set this option to attachment page, gallery shows full-size image.
    I don’t get it, why it works this way.

    Anyway, I disable lightbox plugin for You.

    Any ideas? 🙂

    Theme Author Tom

    (@edge22)

    Hmm, setting the “link to” to “Media File” links to the full image for me.

    Are you using any custom functions on your site at all?

    Thread Starter Ajkub

    (@pudliszewski)

    Hi Tom!

    I don’t use custom functions.

    I make another test. Disable all plugins, but problem is still exist.

    I found that this problem is not only for me (fresh links from 1 week ago):
    https://wordpress.org/support/topic/link-settings-issue/
    https://wordpress.org/support/topic/make-link-to-media-file-point-to-full-size-image/
    https://wordpress.org/support/topic/gallery-media-links-to-large-file-only/

    The good information is that on 99% problem is not in your great theme.

    I wanna ask You for some another tips. Maybe you know code or function, which change all links in gallery block in all posts from 1024x??? to full-size. What do you think? Is it possible? I’m really give up now 🙁

    Theme Author Tom

    (@edge22)

    I did some looking around. Unfortunately, Gutenberg is so new that there isn’t a ton of documentation/articles out there.

    It might be worth opening a ticket within GitHub with them: https://github.com/WordPress/gutenberg

    It should be relatively simple, I just can’t find anything on it for some reason.

    Thread Starter Ajkub

    (@pudliszewski)

    Thanks Tom!

    I appreciate your help.

    Try with problem on github.

    Theme Author Tom

    (@edge22)

    No problem! 🙂

    Hello! I am having the same problem and different one. In “content width” the images are missing only text when they used to be thumbnails for clicking. Thinking this was a plugin problem I’ve changed portfolio plugins and the same problems remain. Help!

    http://reginaldmcdonald.com/portfolio-2/?preview_id=1905&preview_nonce=d1f74d935a&preview=true

    Thanks

    Hi,

    I’ve encountered the same issue. On sandbox copy (WordPress 5.3) the images in the gallery were linked to full-size whereas on production (WordPress 5.1) they were linked to large-size.
    The only difference was the version of WordPress. I’ve upgraded the production to 5.3 and recreated the gallery from scratch and all is fine now.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Gallery-block link to large-size images instead of full-size’ is closed to new replies.