Support » Fixing WordPress » Gah I broke my wordpress

  • Hi guys I am a bit of a new to coding, anyway I had wordpress all setup and running but I had to edit the wp-config and force en_EN language to get a plugin to work (larsens Calender) when I saved the nicely formatted file in notepad and uploaded it I get a funky error

    Parse error: syntax error, unexpected $end in /home/wasabith/public_html/wp-config.php on line 1

    So i downloaded the wp-confid.php again thinking I have made a typo or somethign stupid I open it up in wordpad and its now just 1 very long line of code instead of being all nice and formatted

    <?php/** * The base configurations of the WordPress. * * This file has the following configurations: MySQL settings, Table Prefix, * Secret Keys, WordPress Language, and ABSPATH. You can find more information by * visiting {@link Editing * wp-config.php} Codex page. You can get the MySQL settings from your web host. * * This file is used by the wp-config.php creation script during the * installation. You don't have to use the web site, you can just copy this file * to "wp-config.php" and fill in the values. * * @package WordPress */// ** MySQL settings - You can get this info from your web host ** ///** The name of the database for WordPress */define('DB_NAME', 'wasabith_wrdp1');/** MySQL database username */define('DB_USER', 'XXXXXXXXXXXXXXXXX');/** MySQL database password */define('DB_PASSWORD', 'XXXXXXXXXXXXXX');/** MySQL hostname */define('DB_HOST', 'localhost');/** Database Charset to use in creating database tables. */define('DB_CHARSET', 'utf8');/** The Database Collate type. Don't change this if in doubt. */define('DB_COLLATE', '');/**#@+ * Authentication Unique Keys. * * Change these to different unique phrases! * You can generate these using the {@link secret-key service} * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again. * * @since 2.6.0 */define('AUTH_KEY', 'f7sXx[2wbB@LBwlxS{A56y>+jjQF6Z1H5s6PXz iq\\Ms}?(;_a#ypoR5\'3w<G5>FL~1X');define('SECURE_AUTH_KEY', '-\"r642fed3E1d>}MdGFlh@tR!QPU%/!S_6;CjO0}^>6TjjQF6Z1H5s6P+ <?)3 U#*X;');define('LOGGED_IN_KEY', 'Q^l\"6-pLjjQF6Z1H5s6P\zkw>OG<U$%u0:9H:Jl)+d$~jIBTt&CPL[Dp<KY4zL3y');define('NONCE_KEY', 'asdasdjkasdjkjjQF6Z1H5s6Pjklasdjklasdkl&^%^&*(&*(jklasdjklasdjkl&*)))');/**#@-*//** * WordPress Database Table prefix. * * You can have multiple installations in one database if you give each a unique * prefix. Only numbers, letters, and underscores please! */$table_prefix = 'wp_';/** * WordPress Localized Language, defaults to English. * * Change this to localize WordPress. A corresponding MO file for the chosen * language must be installed to wp-content/languages. For example, install * to wp-content/languages and set WPLANG to 'de' to enable German * language support. */define ('WPLANG', '');/* That's all, stop editing! Happy blogging. *//** WordPress absolute path to the WordPress directory. */if ( !defined('ABSPATH') ) define('ABSPATH', dirname(__FILE__) . '/');/** Sets up WordPress vars and included files. */require_once(ABSPATH . 'wp-settings.php');

    is anyone able to help me reformat this sso I can get my website running again??? 🙁


Viewing 5 replies - 1 through 5 (of 5 total)
  • Start with a new WP config file. Then use Wordpad or a free code editor.

    a hint — ANY plugin that makes you modify core wordpress files isn’t worth using.

    it was only to change the default language as the plugin is written in German and the Fantasticao install of wordpress via Cpanel does not set a default language so the plugin is all in German

    Is it best to install WP again into another directory and steal that config file and jsut change the DB Settings?

    ah no that didnt work

    ergh I think I have to start again

    Woo got it working, downloaded new version of WP and used that config

    Thanks 🙂

    larsens-calender is junk… too bad too, I was hoping for a decent calendar of events too

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Gah I broke my wordpress’ is closed to new replies.