Support » Fixing WordPress » Fatal Error on updating to 3.4

  • Resolved udotorg

    (@udotorg)


    Just updated to the latest version of WordPress. The site I’m working on is relateively new, and I just installed s2member the other day, as well as a handful of other plugins.

    But I just tried to update and got this error:

    Fatal error: Call to undefined method dbrc_wpdb::delete() in /home/thecitiz/public_html/centristsrising.com/wp-includes/option.php on line 370

    I went there, and this is what it is (PHP is not my forte at all):

    [Code moderated as per the Forum Rules. The maximum number of lines of code that you can post in these forums is ten lines. Please use the pastebin]

    `
    Specifically, line 370 is:

    $result = $wpdb->delete( $wpdb->options, array( 'option_name' => $option ) );

    No idea how to fix… please help.

Viewing 13 replies - 1 through 13 (of 13 total)
  • esmi

    (@esmi)

    Forum Moderator

    Try:
    – switching to the Twenty Eleven theme by renaming your current theme’s folder inside wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    mrmist

    (@mrmist)

    Forum Janitor

    esmi

    (@esmi)

    Forum Moderator

    Thanks – I’ll add it to the Master List.

    mrmist – THANK YOU

    Worked like a charm.

    esmi

    (@esmi)

    Forum Moderator

    Cool! That’s one confirmed fix.

    Thank you very much for the link. That saved me from a heart attack.

    I got the same error and fixed it.

    But some plugins still throw me error. Anyone here using Easy-Wp-SEO plugin?

    I was. I was having so many freaking glitches that I couldn’t track down that I decided to just up and start over. Now I’m having all sorts of issues just trying to install the darn thing, that I’ve never run into before. Currently stuck in a redirect loop when I just try to install.

    I had the same problem, only I am not using the DB Cache plugin so that wasn’t what was causing the problem. I follows esmi advice on
    -re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress

    and it now works, but I didn’t actually disable any plug-ins, so I don’t know what the cause was.

    I’m really hesitant to upgrade to 3.4 on my other site, which is actually live and gets tens of thousands of hits a month… this site was still in development so I just saved some stuff and started over.

    Guido Walter

    (@guidowalteryahoocom)

    Still need help. I tried all the solutions here but still have the same problem and I need help with this.

    Hi same problem here, and I have tried all the options listed above. any other ideas? please.

    WPyogi

    (@wpyogi)

    Forum Moderator

    Yes, please start your own thread – this one is old and quite outdated and thus not likely relevant.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Fatal Error on updating to 3.4’ is closed to new replies.