Google Analytics Dashboard for WP
[resolved] GA Dashboard problems with Subdomain (6 posts)

  1. ben_g
    Posted 1 year ago #

    Hi Guys

    I seem to be having trouble getting just the GA Dashboard Widget information for just my domain or my subdomain. The websites are hosted by same provider, both have a seperate WP installation in sep folders, both WPs have GA Dashboard installed and both are showing the same information.

    In my Google Account i've 1 property and i've created 2 new views (1x domain and 1x subdomain) with filters "include only" "traffic to hostname" "that contains" and then the hostname.

    How can i go about choosing these views from within the GA Dashboard in WP?

    Apologies had no success in finding this infos in documentation.

    Thanks for your assistance on this!


  2. Alin Marcu
    Plugin Author

    Posted 1 year ago #

    Look closely to your Select Domain option, when you hover the domain name a View Name: tootltip will indicate the correct view to select for each website. If you don't see two items listed in that list you should clear the authorization and authorize again, it will force a property/view update.

  3. ben_g
    Posted 1 year ago #

    Hi Alin

    The hovering wasn't showing anything so i cleared and reauthorized both the main and subdomain and that seems to have done the trick.

    Thanks for clearing that up.

  4. nomadarod
    Posted 5 months ago #

    My case is very similar to this one, because I also have a domain and a subdomain, with independent WP installs in each. In the main domain I'm using Piwik. I'm experimenting GA Dashboard for WordPress on my subdomain.

    I've followed the tutorial and selected my subdomain's web property with "All Web Site Data" attached. (Domain and subdomain are as different properties in GA)

    The Google Analytics tracking code status is as "Tracking Not Installed".

    I've been around the tutorials for both the plugin and GA but couldn't find anything on how to fix this. Any clues?


  5. Alin Marcu
    Plugin Author

    Posted 5 months ago #

    @nomadarod actually your problem is not similar at all to this one, you should rather look here: https://wordpress.org/support/topic/tracking-not-installed-tried-troubleshooting?replies=2

    One thing I've spotted, which is also covered in the FAQ page is that your code is duplicated. Check the topic mentioned above for further details.

  6. nomadarod
    Posted 5 months ago #

    Thanks.followed your link and tested. But still not working. Will reply in the post you linked instead.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google Analytics Dashboard for WP
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic