Support » Plugin: Fast Velocity Minify » FVM Purge issue with WP Super Cache

  • Resolved G

    (@gnetworkau)


    Hi Raul, thanks again as FVM has been a solid performer and improving for quite a while now. Recently however, I have found anomalies after updates over the last month or so.

    Currently the FVM Purge feature is causing problems. It works fine manually as it purges all FVM and WP Super Cache files, but when any site updates occur, it automatically purges FVM files, but leaves the supercache files untouched. Then of course the pages reference non-existent resources, causing display issues.

    Is there a way to either:
    1. Force it to purge both caches upon updates OR
    2. Disable the automatic purge completely

    I have tried the new option you made
    “Preserve Cache Files [ This will reload your cache files when you purge, but preserve the old files ]”
    but this made no difference.

    What to do?

Viewing 10 replies - 1 through 10 (of 10 total)
  • G

    (@gnetworkau)

    Raul, don’t worry about this issue for now. I realised that I had not set “Preserve Cache Files” on all sites in the network. I have done so now and monitoring to see if it does keep working. Will post here in a few days if it holds up ok.

    Plugin Author Raul P.

    (@alignak)

    Indeed, you would have to set the settings on a per site case scenario.

    The cache purge however, “should” purge the whole cache completely for all sites.
    In the future, I’ll try to check if it’s possible to delete each site cache separately instead.

    Thanks for letting me know.

    G

    (@gnetworkau)

    Hi Raul, seems to be holding up ok.
    I like how it works now, and yes it should purge for all sites as they share the same files, plugins, settings from network, etc – I think best to keep it like that.

    If anything, it would be nice to make it an option to either:
    1. Purge all cahes upon updates – including html cache (supercache) OR
    2. Disable automatic cache purge completely.

    I would like to see this as a Network setting.

    Thanks again, FVM is the best!

    Hi Paul

    I seem to be getting the same problem. It is fine and fixes the issue when you purge manually but then when I check hours later all the styles are missing and can’t find the css file reference.

    I have set it to inline everything at the moment so there is no css file to include but am now worried about the JavaScript merged files.

    Will check later on as see if it happens again.

    FVM was installed via the porto theme optimise setup along with the stackCache plugin.

    Regards
    Andy

    Plugin Author Raul P.

    (@alignak)

    @andrewc41 it seems you have some stalled cache, that’s why.

    When you purge the cache, or when FVM asks for a cache purge, not all cache is being purged for some reason.

    I’ve seen this happening before, not with FVM but in other situations were I hit cache purge, and not all the cache is cleared.

    It’s more common in high traffic sites (because file locking happens), if the site is too large (large cache), or have slow disks, or even if you use a LEMP stack (which is what I use actually).

    As stated on the first post, you must select:

    “Preserve Cache Files [ This will reload your cache files when you purge, but preserve the old files ]”

    That way, even with stalled cached on supercache, the old fvm files are not gone.

    Plugin Author Raul P.

    (@alignak)

    @andrewc41 & @gnetworkau

    I pushed the 2.6.0 update, which “should” prevent these issues in the future.

    Thanks

    Hi Paul

    Thank you so much! I have done the update and all good so far.

    Thanks

    G

    (@gnetworkau)

    Raul, the 2.6.0 works ok. Without option “Preserve Cache Files [ This will reload your cache files when you purge, but preserve the old files ]” – how will it preserve the files?

    For your information, on my multisite the URL format is like so:
    https://domain.com/wp-content/cache/cache/fvm/1551567105/out/header-944e32cb.min.css
    Notice the /cache/cache/…

    In settings I have “Cache Location”
    Cache: /home/user/public_html/wp-content/cache
    Path: https://domain.com/wp-content/cache

    Plugin Author Raul P.

    (@alignak)

    @gnetworkau It now preserves the public files for 3 months, and a daily cron job will do the cleanup. That should be plenty of time to any cache plugin to expire.

    For the double cache/cache thing, it happens because your customized directory is also named cache and the plugin creates a cache directory inside whatever directory you define.

    The default is now wp-content/cache/fvm... for single sites install.
    For multisite, it will be /wp-content/uploads/sites/ID/cache/fvm…

    Note I do not recommend defining a single directory for all sites on a network.

    Each site should have it’s own directory, to prevent cache collisions, especially if you use the same theme. It will probably still work fine if you are using subdomains, but resources inside the css files may be loading from another site.

    You can default a custom path inside the cache directory for each site, perhaps.
    /home/user/public_html/wp-content/cache/site1, /home/user/public_html/wp-content/cache/site2, etc and then update FVM for each site accordingly.

    G

    (@gnetworkau)

    @alignak thanks for clarification Raul. I will do custom path for each site, all inside one cache directory. The reason I prefer this, is that if there are any problems clearing cache, I can use ftp and delete in just one directory.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘FVM Purge issue with WP Super Cache’ is closed to new replies.