Support » Plugin: Fast Velocity Minify » FVM not compatible with the latest Elementor version

  • Resolved hkim00

    (@hkim00)


    FVM is not working with the latest Elementor versions. It has worked with previous versions of Elementor, but I guess they changed something in the latest version. This very combination now breaks the formatting of my page.

    I have really enjoyed FVM but I think an update would be good.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Raul P.

    (@alignak)

    That sounds like some lazy loading issue. Did they introduce something on elementor that lazy loads images, perhaps?

    Merging CSS can cause that, if they use wrong specificities. If that’s the case, even if you copy paste all css into one file, it’s going to cause the same issue and there’s not much you can do about it, other than to change the order of those css that need to come later.

    The other option is that they may have implemented a bug on one of their JS libraries. Are there any errors on the google chrome console log?
    It doesn’t need to be elementor… it could be some other js file from the theme or another plugin. If there are js errors, it will show up when you merge them with FVM.

    You can follow the faqs here and play with the ignore list.
    Try to find out if it’s a js or css issue first.
    Try other options, such as inlining css instead of merging.
    https://wordpress.org/plugins/fast-velocity-minify/faq/

    If there is any lazy loading option on your theme (such as the newspapper theme), disable it and use a lazy loading plugin instead. That theme implementation is not very good and causes conflicts when you merge files.

    Which theme are you using?
    If you have a staging version of your site, send me access via fastvelocity.com contact form and I’ll take a look.

    hkim00

    (@hkim00)

    I have followed your guidelines, but no matter what you change in FVM, the errors prevails with the latest version of Elementor. I’m using Astra theme Pro. No change in my setting other than the update of Elementor.

    No, the latest version of Elementor did not introduce lazy loading of images. It was a bug-fixing release, and I guess they introduced a new bug…

    It is probably nothing with FVM but if you could look into this would be great. I have also opened an issue with Elementor.

    hkim00

    (@hkim00)

    Btw, FVM is the most effective optimizing plugin out there. Tested every plugin out there, and no one gets me 95%/97% on GMetrix and 60 (mobile)/92 (desktop) on PSI.

    • This reply was modified 8 months ago by hkim00.
    sermalefico

    (@sermalefico)

    In the last versions of Elementor they made some changes so that in its editor it loads lighter. But this made us not face this problem. Because those changes were applied to the frontend. I had to add an exception to this file /elementor/assets/js/frontend.min.js
    It’s a pain because everything worked correctly before.

    this is the error that comes out without putting the exception:

    Uncaught TypeError: Cannot read property ‘environmentMode’ of undefined

    Plugin Author Raul P.

    (@alignak)

    @sermalefico for the frontend editor, make sure to select the option to fix page editors on FVM, that’s what the option exists for and there is no need to play with the ignore list for that.

    @hkim00

    If the error is Uncaught TypeError: Cannot read property ‘environmentMode’ of undefined that basically means, that the javascript code they use has 2 steps. One file (the one you ignored) and some inlined JS code.

    When FVM merges the JS files, it doesn’t merge the inline JS code, because some plugins rename some of the code on every page load and FVM cache would just grow forever.

    Therefore, if we merge some JS files or if we defer them, what happens is that the inline JS code will reference one of those files, however, because we now merged and deferred all external JS files, that merged file loads “after” the inlined script.

    Inlined scripts are render blocking, so if that code “depends” on an external library or js file, that library/js file must load before it. That’s why the ignore list exists, so we can fix these types of errors.

    So for now, the solution seems to be to add that file to the ignore list.
    I’ll do some testing asap and then see if I can push some update for this as well.

    sermalefico

    (@sermalefico)

    @alignak Yes I know. But the problem this appears when you are not logged in the frontend. In the backend everything works perfectly. it must be because it loads some type of script online or external

    buysellng

    (@buysellng)

    I have the same problem with FVM. After update, I have been getting error. Website is broken. I have temporarily reverted to previous version of elementor but its not the safest option.
    I have sent message to FVM as well. I hope there is solution to this. Raul please help.
    What should be the file that should be added to ignore list?
    I temporarily used autoptimize and it works fine but i prefer FVM.

    Plugin Author Raul P.

    (@alignak)

    @buysellng I haven’t tried it yet, but it seems to be /elementor/assets/js/frontend.min.js

    Autoptimize works because it reads and merges inline code, while FVM only merges the files and uses other techniques.

    I’ll have an update soon for that, but for now, try to add that file to the ignore list.

    buysellng

    (@buysellng)

    Thank you. Error is fixed for now. Hope to get an update.

    buysellng

    (@buysellng)

    Few more errors. The following showed errors addons.min.js and jquery.js after adding above to ignore list.
    Hmm

    hkim00

    (@hkim00)

    Well for me and my configuration, it worked fine by excluding the js-file. So the errors you are experiencing might be caused by something else.

    niklas96

    (@niklas96)

    I’ve got the same problem, but unfortunately adding /elementor/assets/js/frontend.min.js

    to the ignore list doesn’t work for me.

    I do not get any further errors, but my time to first byte time increased significantly. Additionally I also am not able to display a part of my homepage content.

    Any ideas?

    • This reply was modified 8 months ago by niklas96.
    qwik3r

    (@qwik3r)

    Also getting environmentMode is undefined, even after adding the frontend.js to exclusions.

    • This reply was modified 8 months ago by qwik3r.
    Plugin Author Raul P.

    (@alignak)

    Thanks @qwik3r @niklas96 @hkim00 @buysellng @sermalefico for all the info.

    Elementor introduced a few changes during editing and changed logic in some part, which breaks merging and minification on most plugins.

    I pushed version 2.6.1 which seems to be working on my test sites, so feel free to update and try again.

    If it doesn’t fully work, you can add this to the ignore list as well:

    /plugins/elementor/
    /plugins/elementor-pro/

    Thanks

    I’ll check it out. Thank you. Just out of curiosity, is it redundant to run FVM in parallel to Autoptimize?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘FVM not compatible with the latest Elementor version’ is closed to new replies.