Support » Plugin: Fast Velocity Minify » FVM cache size always (0.00 B) and no css or js are processed

  • Resolved sanfrhkjzfcg

    (@sanfrhkjzfcg)


    Hi

    First, I really want to appreciate you for this awesome plugin that u have made. such a master piece bro

    the problem : I dont know what happened but suddenly I noticed the “FVM cache size” in status tab, is always (0.00 B) and no css or js are processed and my website’s appearnce looks broken when I enable plugin.

    any idea about what can cause this problem?

    thanks agn

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Raul P.

    (@alignak)

    Hi @sanfrhkjzfcg

    From what I’ve seen in a few cases, it seems to be a file permissions error.
    Most of the time, those users are also using openlitespeed servers.

    Is that the case for you?
    What is your website url?

    What is happening there, is that PHP is trying to save the minified file, but for some reason, the files are not being created.
    This only happens for 1 of 2 reasons… either the file path is wrong, or the server is blocking the files from being written.

    To check if the path is correct, it’s easy…
    When you install FVM and go to the “Pro” Tab, scroll down and see the section for the cache location. It will show you the path to the uploads/fvm directory (under the text box).

    If the path exists on your server (you can check with FTP/SFTP, some control panel file manager, etc).

    To check file permissions, please compare if the file permissions on wp-content/uploads/fvm are the same as the main wp-content/uploads directory.

    By default, the plugin creates them with the default chmod 0755 which is fine on most cases. Some hosting providers and some setups however, seem to require other type of permissions, such as 2770, 2775 or even 4777… which, unless you are the only user in that server, is usually unsafe.

    https://www.dummies.com/web-design-development/wordpress/navigation-customization/how-to-change-file-permissions-using-filezilla-on-your-ftp-site/

    Plugin Author Raul P.

    (@alignak)

    Hi again

    @sanfrhkjzfcg

    I did some testing on my end and I just pushed version 2.4.8 with a new method of checking the file permissions.

    It now tries to replicate the settings of your uploads directory, so in theory, it will replicate whatever permissions your uploads directory has, regardless of whatever it is set to.

    It still doesn’t explain why your host has different settings than the normal, or why they perhaps have a different umask setting son the server, but version 2.4.8 will try to ignore that.

    Either way, please let me know if it works.

    Thanks

    Hi there

    the plugin was working fine some days ago and I really dont know what happened suddenly.

    I checked the directory and permissions and everything were looking fine.

    now, Just updated to the new version that is with a new method of checking the file permissions.

    the problem is solved now.

    thanks for your help

    Plugin Author Raul P.

    (@alignak)

    Thanks for reporting back, glad it works 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘FVM cache size always (0.00 B) and no css or js are processed’ is closed to new replies.