Support » Fixing WordPress » Funny characters after server move: ÂÂ

  • PKYI

    (@pkyi)


    I am seeing funny characters after a server move:  .

    Those characters tend to show up after periods.

    Can anyone tell me what I’m doing wrong?

    Using version 2.2.

Viewing 15 replies - 1 through 15 (of 26 total)
  • jamespoling

    (@jamespoling)

    join the crowd. The exact same thing happened to me. I have a thread started here: http://wordpress.org/support/topic/120562?replies=3

    I used phpMyAdmin to export and import the DB. I tried adding the charset code to the wp-db.php file and a couple of other files I found on here, but there doesn’t seem to be one solid solution.

    This seems to be a very odd problem and even more frustrating that there doesn’t seem to be an easy solution.

    I am also using 2.2.

    I am currently having someone try to export/import the database using SSH to see if the same problem happens. If it does then this seems like a pretty major issue that needs to be fixed.

    MichaelH

    (@michaelh)

    Please, could you post your complete wp-config-php file to http://wordpress.pastebin.ca/ and report the link back here.

    Is that the same wp-config.php you used for both the old and new host? If not please post both versions if you can.

    Can you describe the export for the old database and the import to the new database procedure you followed?

    What did you use to create the new database?

    jamespoling

    (@jamespoling)

    NEW: http://wordpress.pastebin.ca/538910

    OLD: http://wordpress.pastebin.ca/538928

    I just realized I didn’t add the charset code to the old one, although I am sure at one point I did. I’ve been trying it for days.

    moshu

    (@moshu)

    Actually that’s the point: in the old config file you didn’t need the charset (and collation) line and when upgrading your WP you should NOT add those!

    moshu

    (@moshu)

    @pkyi,
    Are you from the the old school (=paper + typewriter) and hitting the space TWICE after a period? Don’t do it! This is a different medium with different rules.

    jamespoling

    (@jamespoling)

    I’m not upgrading, I’m migrating, and the characters here there whether or not I added that to the wp-config.php file or not. That’s why I added it to the new one because it did happen in the first place.

    Also, is that true? I always use two spaces after a period. And yes I did learn that back from typewriter days. Damn, I’m still doing it.

    PKYI

    (@pkyi)

    OLD

    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘beave8_wrdp1’); // The name of the database
    define(‘DB_USER’, ‘beave8_wrdp1’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘*******’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value

    NEW

    <?php
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘umill3_wrdp1’); // The name of the database
    define(‘DB_USER’, ‘umill3_wrdp1’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘*******’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value
    define(‘DB_CHARSET’, ‘utf8’);
    define(‘DB_COLLATE’, ”);

    I downloaded old sql via Php myadmin. EXCEPT for the options table.

    Then I installed a fresh install of ver. 2.2 on my new server. Then I went into php myadmin and clicked on SQL tab, and inserted the SQL queries of old database into the box. and hit enter.

    Hope this helps.

    I would delete those weird symbols manually, but I have a LOT of entries.

    @moshu, Yes, I think I use double tab, double space a lot. 🙁

    moshu

    (@moshu)

    Ah, with migrating it is always a mess – but that’s a MySQL issue. Even this forum got screwed up more than a year ago when the devs moved it to another server with a different MySQL version. You can find older posts with “funny characters”.

    It’s getting late here and I can’t remember where did I see some notes about migration. Where the two MySQL databases of the same version?

    moshu

    (@moshu)

    PKYI,
    you didn’t mention till now it was a move.
    (I hope those passwords were not real – anyway, I deleted them!)
    No, you don’t need the two lines about charset and collation. Delete them!
    Those lines are for brand new installations not upgrades and/or moved blogs.

    jamespoling

    (@jamespoling)

    Moshu, you keep saying we don’t need those two lines but the only reason, at least for me those lines were added was because I had the issue originally without the two lines.

    BigBri

    (@bigbri)

    jamideleon

    (@jamideleon)

    I have the same problem because of the upgrade to WP 2.2, if I remove the two lines in wp-config.php will it remove all the Â’s automatically or I still need to remove them manually?

    Â Â Â – I too am having trouble figuring out how to change my new upgrade to stop those annoying symbols. I was just advised to upgrade to 2.2, then found that I need to now upgrade to 2.2.1?
    I use fantastico thru my webhost and am having a bit of trouble with exactly what to do to fix this bug.
    thank you for any advice.

    Deleting the two lines:

    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    Did the trick for me when upgrading using Fantastico.

    I deleted the two lines, and it got rid of the  characters, but now there are some (not as many) question mark ??? characters where the  used to be.

    Any ideas on this one?

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘Funny characters after server move: ’ is closed to new replies.