Support » Fixing WordPress » Functions.php not working

  • So here is how it all went down.
    I have had a lot of spammers register on my site, so after getting a ridiculous spam groups, I decided(finally) to download a Captcha plugin. Foolish me; I installed it too late. I had 4,000 groups and no way to delete it. I tried to delete it all at once; no good. My crummy hosting collapsed. After waiting a day I tried again; this time I did it by 20 groups. Instead of deleting the groups however, bulk delete just refreshed the page. I looked up this problem and came to the conclusion that I had to edit the dreaded functions.php file. I hated editing this; I have had bad experiences before involving my site getting completely erased, but that is another story. I inserted the function I was supposed to insert, crossed my fingers and hit submit. What I had feared had happened; instead of going to my home page my site lead directly to an error message. Ok. Easy. I’ll just undo what I did.
    Now here’s the problem:
    No matter what I did to the function file, I couldn’t fix it. After awhile I got frustrated and downloaded a fresh functions.php. This is where I completely raged; It still didn’t work. The error message didn’t make any sense, either:
    Parse error: syntax error, unexpected ‘*’ in /home/jonat456/public_html/wp/wp-content/themes/frisco-for-buddypress/functions.php on line 18
    What did I do wrong? Now I am no expert in php, but I am pretty sure the general rule is *=ignore. Why isn’t it? I even tried deleting line 18, to no avail? Anyone that can help, please respond ASAP. Even if your not sure, please put it out anyway for me to try.

    Thanks(and hurry!),
    Jonathan Kim
    Website that is down:

  • The topic ‘Functions.php not working’ is closed to new replies.