Support » Theme: Custom Community » Functions.php error on top of dash

  • Resolved crismas


    I had an issue last week where my site wasn’t loading (would go to no data every time I tried accessing the site). I spoke with my host and they informed me there was an issue with a couple of plugins which they renamed and since then I had deleted.

    While it’s back to normal use at this point, an error/notice has popped up on the top of the WordPress dash:

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /hermes/waloraweb052/b2302/pow./htdocs/a/wp-includes/functions.php on line 3017 Notice: Trying to get property of non-object in /hermes/waloraweb052/b2302/pow./htdocs/a/wp-content/themes/custom-community/functions.php on line 1184 Notice: Trying to get property of non-object in /hermes/waloraweb052/b2302/pow./htdocs/a/wp-content/themes/custom-community/functions.php on line 1184

    I’m not exactly sure what to fix. It’s possible my host messed around with something as they first thought something was wrong with custom community theme itself (which turns out there wasn’t after I went back and forth with them). I was hoping someone can help with this.

    I’m currently using version 1.17.3 of the theme for reference.

    Thanks so much!

Viewing 4 replies - 1 through 4 (of 4 total)
  • If you feel your host has modified the theme’s files you can always remove the modified file and replace it with a new one from here

    Or even remove the theme and upload a new copy of it.

    I guess the has_cap error is related to a plugin. Try disabling each plugin to find the one causing it.

    To simply ignore and hide these notices turn off WP_DEBUG by editing the wp-config.php file and changing

    define( 'WP_DEBUG', true );


    define( 'WP_DEBUG', false );

    Ok I’ll try that, thanks so much!

    I tried deactivating some plugins which worked. But there was still one plugin causing the message which I had been using for a while now. The debug to false worked though in getting rid of the messages completely. Thanks for the help again!

    You’re welcome!!

    Just make sure you’re running the latest version of WordPress and all plugins.

    If a plugin page says

    This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

    you should avoid them and look for alternatives.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Functions.php error on top of dash’ is closed to new replies.