functions-post.php fix question for Ryan or other Guru (9 posts)

  1. kickass
    Posted 9 years ago #

    I've got two installs of 2.0 I'm going to be doing and I'm trying to get ducks in a row BEFORE installing. Both these installations will need working permalinks so I snagged the functions-post.php and classes.php updates from this post:

    Both these installations are also going to require the use of third party editor uploads (audioblog or similar) so I tried to, on this fixed functions-post.php file, do the changes that are talked about on the trac here:

    The first fix, 3376, was already fixed in the permalink patched version, but the other two (3377 and 3378) there aren't matching sections to fix, or at least not near enough for me with my limited php experience to recognize as such. I have completed the xmlrpc.php fix. Could Ryan or someone give me good instructions on how to do the fix to functions-post.php? Or, perhaps, post an already fixed file that will work in both situations?


  2. kickass
    Posted 9 years ago #


  3. vkaryl
    Posted 9 years ago #

    Gosh, I thought ryan said there was already a "drop-in" file. I must have missed some later developments, but search being what it is (or isn't in this case), I can't find the threads I thought I remembered reading.

    I'll keep looking....

  4. PetLvr
    Posted 9 years ago #

    As I am still experiencing permalink problems - I continue in my search to FIX this ...

    Just noticed this - perhaps RYAN can look at..

    This thread:
    Mikae1 mentioned that the fixes supplied by ryan helped him ..

    functions-post.php > rev 3390
    classes.php > rev 3395

    Below that in a later point in the thread, he "cleans" up the link and provides an easier way to dowload..

    functions-post.php > rev 3390
    classes.php > rev 3396

    It's these last two links that I updated my wp-admin files with .. could this be the cause? Should the classes.php file be downgraded? Maybe that will work?

    I'm still concerned with http://The-Singers.com - permalinks only works with the default /?=pXXX etc where I want /category/postname rule.

  5. moshu
    Posted 9 years ago #

    in this post Ryan posted a link to a build
    I am using that in a test site and all the permalinks work perfectly.

    p.s. where I want /category/postname rule
    Using the category might be problematic if your server/host has an earlier Apache - see:
    there is a Note somewhere about using the category (Codex down again?)

  6. PetLvr
    Posted 9 years ago #

    Hi Moshu .. My site doesn't use a subfolder for the blog so the first link (i think) doesn't help me.

    As for the second link .. looking back, that article was the reason I totally crashed my server offline with the Lucky13Apache plugin ... I don't think I need it (now) but thought I needed it (then) .. From my cPanel, this is what shows up as server information:

    Operating system Linux
    Service Status Click to View
    Kernel version 2.4.20-021stab028.19.777-smp
    Machine Type i686
    Apache version 1.3.34 (Unix)
    PERL version 5.8.7
    Path to PERL /usr/bin/perl
    Path to sendmail /usr/sbin/sendmail
    Installed Perl Modules Click to View
    PHP version 5.0.4
    MySQL version 4.1.14-standard
    cPanel Build 10.8.1-RELEASE 95
    Theme cPanel X v2.5.0
    Documentation Click to View

    Should I take notice of anything?'


  7. moshu
    Posted 9 years ago #

    Who talked about a subfolder?
    I said there is a LINK in that post to a WP nightly build that should work, because it has a lot of bugs fixed. At least it works for me. Even with the category/postname structure; but, of course, we are not on the same server.

    kickass, sorry for hijacking your thread :(

  8. kickass
    Posted 9 years ago #

    That's okay, I didn't know about that all-inclusive newer build, hopefully it also has the fixes I need for the third party stuff like audioblog. Ryan said he'd post a fixed file for that for pcMike but if he did I never saw it, and none of the line numbers coincide anymore if you try to follow things from trac. Hopefully it's in that download.

  9. kickass
    Posted 9 years ago #

    And if anyone is posting directly from audioblog or ecto or one of those, can you tell me what you did?

Topic Closed

This topic has been closed to new replies.

About this Topic