[Resolved] Functions Naming Style
I am recently started using wordpress and realized that its the great cms. Using wordpress we can make any kind of website even if its primarily build for bloging sites because of its simplicity, flexibility and lots of built-in functions.
But I feel that there is no uniformity in naming style of wordpress functions. ie. Some start with ‘wp_’ to indicate that its wordpress function and some don’t like ‘get_posts’.
I don’t find it logically correct. It may be because of lack of knowledge of wordpress.
But uniformity in naming style helps us to guess the functions without searching the function in codex. Also it makes a standard and logically correct.
Please correct me if I am going wrong.
Thanks for making such a great cms.
- The topic ‘[Resolved] Functions Naming Style’ is closed to new replies.