WordPress.org

Forums

WP-Optimize
[resolved] "Functions File is missing!" (36 posts)

  1. Igor Isaias Banlian
    Member
    Posted 1 year ago #

    My site does not work at all any more after I upgrade the plugin to version 1.5.1!

    On every page the error appears:

    "Functions File is missing!"

    I had to go back to the previous version (1.1.2)!

    Regards,
    Igor Isaias Banlian

    http://wordpress.org/plugins/wp-optimize/

  2. ruhanirabin
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Could you remove the previous version of the plugin .. deactivate and delete and try to install the new one.. I can see the function file is there. Sometimes wordpress do not update it in time. Let me know thanks.

  3. I have the same error. Cannot access the dashboard or site: error shows "Funtions File is missing!"

  4. Ruhani, I just tried your suggestion, and I get the same error message, but this time, it says "Plugin could not be activated because it triggered a fatal error. Functions file is missing!"

  5. ruhanirabin
    Member
    Plugin Author

    Posted 1 year ago #

    Unfortunately I tried it on 5 of my websites .. none can reproduce this problem.. can you tell me what wordpress version and what server you are running it on. Beside that .. ftp to the wp-optimize directory and look for a file called wp-optimize-common.php .. if this file is missing then wordpress did not correctly updated the files. If it is there, then the server may be adding an extra slash to the file path. I need to have a bit more info on this. Thanks for helping me out guys.

  6. I guess it was only rendering site & dashboard inoperable when I was attempting a one-click update with the plugin activated.

  7. ruhanirabin
    Member
    Plugin Author

    Posted 1 year ago #

    I did the same thing actually.. i am suspecting it is a path issue..

  8. flagged
    Member
    Posted 1 year ago #

    I'm having the same exact problem after upgrading my plugins from wp-admin

  9. Igor Isaias Banlian
    Member
    Posted 1 year ago #

    Ruhani, clearly there is a bug in the current version of the plugin that is causing this error!

    Please investigate what might be happening!

    Regards,
    Igor Isaias Banlian

  10. ConservTeacher
    Member
    Posted 1 year ago #

    Same problem! This sucks! I can't get into anything on my site.

  11. ruhanirabin
    Member
    Plugin Author

    Posted 1 year ago #

    delete the folder if you are having problems accessing site admin..

  12. ConservTeacher
    Member
    Posted 1 year ago #

    Thanks, that allowed me back in to the site.

  13. ruhanirabin
    Member
    Plugin Author

    Posted 1 year ago #

    I need to apply a patch .. can any one of you guys can help me test it? I am unable to replicate it on any of my site.. but i am sure it is a path issue .. i need at least one of you guys to try a patch out. Once it is confirmed i can apply the patch globally.

  14. Nostrodamus
    Member
    Posted 1 year ago #

    I just updated the plugin from the admin panel and now I cannot access anything
    All I get is
    Functions+File+is+missing!
    Please help as I am now totally lost

  15. ruhanirabin
    Member
    Plugin Author

    Posted 1 year ago #

    Nostrodamus, which version did you update to ? ftp to your host and delete the folder - /wp-content/plugins/wp-optimize .. that will let you into your wp-admin. I have deplyed a possible fix at version 1.5.2 .. let me know if that works.

  16. markmelch
    Member
    Posted 1 year ago #

    I had this happen on 3 sites tonight after updating the plugin:

    Warning: include_once(__DIR__/wp-optimize-main.php) [function.include-once]: failed to open stream: No such file or directory in /public_html/wp-content/plugins/wp-optimize/wp-optimize-admin.php on line 88
    
    Warning: include_once() [function.include]: Failed opening '__DIR__/wp-optimize-main.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /public_html/wp-content/plugins/wp-optimize/wp-optimize-admin.php on line 88

    The site is not affected but I cannot access WP Optimize.

    I deleted the plugin and FTP'd a fresh copy but I still get this error.

  17. Nostrodamus
    Member
    Posted 1 year ago #

    How do I delete the plugin so I can get access to my site and admin until the problem is resolved.
    Which file do I delete?

  18. ruhanirabin
    Member
    Plugin Author

    Posted 1 year ago #

    ftp to your site and delete the folder - /wp-content/plugins/wp-optimize

  19. ruhanirabin
    Member
    Plugin Author

    Posted 1 year ago #

    @markmelch, i am going to take a look into that, it seems to be the similar problem with path too. Did you upgrade to 1.5.2 yet?

  20. markmelch
    Member
    Posted 1 year ago #

    @Nostrodamus

    You need to FTP or cPanel. Navigate to /public_html/wp-content/plugins/wp-optimize

    Delete the wp-optimize folder and contents

  21. ruhanirabin
    Member
    Plugin Author

    Posted 1 year ago #

    @markmelch. thank u .. would you like to try out a patch?

  22. Nostrodamus
    Member
    Posted 1 year ago #

    markmelch
    Thanks for that
    Just did it and uploaded 1.5.2 and that version seems to work fine..I have my access back again to admin and the site.

  23. Igor Isaias Banlian
    Member
    Posted 1 year ago #

    Now I'm getting the same error that Mark:

    Warning: include_once(__DIR__/wp-optimize-main.php) [function.include-once]: failed to open stream: No such file or directory in /home/extre674/public_html/vhackerclube/wp-content/plugins/wp-optimize/wp-optimize-admin.php on line 88
    
    Warning: include_once() [function.include]: Failed opening '__DIR__/wp-optimize-main.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/extre674/public_html/vhackerclube/wp-content/plugins/wp-optimize/wp-optimize-admin.php on line 88

    There is already a solution?

    Regards,
    Igor Isaias Banlian

  24. Nostrodamus
    Member
    Posted 1 year ago #

    I deleted the wp-optimize folder and got all my access back again... I have now downloaded 1.5.2 but all I get are the three tab headings when I go to the program..there is nothing else there apart from a blank screen.
    I deactivated it, deleted it and re installed but it is still the same..just the tabs and nothing else.

  25. ruhanirabin
    Member
    Plugin Author

    Posted 1 year ago #

    Posted another fix - 1.5.3

  26. Igor Isaias Banlian
    Member
    Posted 1 year ago #

    Replace:
    __DIR__

    with:
    dirname(__FILE__)

    In the three entries from file:

    /wp-content/plugins/wp-optimize/wp-optimize-admin.php

    and problem solved!

    Source: http://wordpress.org/support/topic/plugin-sightings-file-error?replies=7

    Regards,
    Igor Isaias Banlian

  27. Igor Isaias Banlian
    Member
    Posted 1 year ago #

    More information about why this problem has occurred: http://www.electrictoolbox.com/php-quick-tip-dir-for-dirname-file/

    Regards,
    Igor Isaias Banlian

  28. ruhanirabin
    Member
    Plugin Author

    Posted 1 year ago #

    dirname(__FILE__) does not return slashes. i already posted proper wp function for it. plugin_dir_path( __FILE__ )

  29. ruhanirabin
    Member
    Plugin Author

    Posted 1 year ago #

    Please update to latest and post feedback. thanks everyone.

  30. Nostrodamus
    Member
    Posted 1 year ago #

    The latest version seems to have everything back to normal...
    I know you must have been working frantically.
    Thank you

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP-Optimize
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.