function.php error and Wp stop working (6 posts)

  1. umerkakar
    Posted 3 years ago #

    Salam everyone,
    I am creating theme for my website for 1st time in worpress. And i go help and collect codes from here and there and combine them for working. I created theme on PC WP and when I upload theme to website Network home admin panel becomes inactive with white pages, and when I open any network site pannel its worked. So I delete function.php from my control panel and then network home becomes active. Then I repeat upload file and again WP stop working. So, plz someone help me to correct my codes. I writing down my function php script under and some others.

    Tjis is function php page codes:

    [ 269 lines of code moderated. For more than 10 lines of code please pastebin.com instead. ]

    I think error is one of these file, please Masters help me. Thanks


  2. Chip Bennett
    Theme Review Admin
    Posted 3 years ago #

    Seriously: use Pastebin for code longer than about 10 lines.

    As for your specific problem: I would recommend starting with a blank functions.php file, and verify that the site works.

    Then, restore each part of functions.php, line-by-line or function-by-function (as appropriate), to determine what code is causing the error. Be sure that you have enabled WP_DEBUG, so that you can see the Fatal Error(s) being generated.

  3. umerkakar
    Posted 3 years ago #

    Thanks for good advice, شکریہ

  4. umerkakar
    Posted 3 years ago #

    I found problem when I delete the line of settings.php its ok when again I copy again the include code its stop work. Now what I do.


    # Sidebar
    if (function_exists('register_sidebar'))
    'name' => 'Full Width Widget',
    'before_widget' => '',
    'after_widget' => '</div>',
    'before_title' => '<h3>',
    'after_title' => '</h3><div class="box">',

  5. s_ha_dum
    Posted 3 years ago #

    You are talking about 'functions.php' inside your theme folder, right?

    You don't want to include 'settings.php' in your 'functions.php' file. Try without that 'include' line.

  6. umerkakar
    Posted 3 years ago #

    yes this was the problem, if you ask me i will email your the files via email or ion the bolg and help me to get rid from the problem

Topic Closed

This topic has been closed to new replies.

About this Topic