WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Function compat_is_wordpress_mu does not work as it should

[Resolved] Function compat_is_wordpress_mu does not work as it should

  • brasofilo
    Member

    @brasofilo

    Hi, Bravers!

    Intrigued on why WPTouch was uploading files into wp-content/blogs.dir/ when I’m using a Single Site installation, I just seen the motive:

    You are detecting Multisite by the existence of the folder wp-content/mu-plugins.

    This folder stands for Must Use plugin. It has nothing to do with the site being Multisite (the old MultiUser) or not.

    The correct is to use the function is_multisite(). You can completely drop the use of compat_is_wordpress_mu and use that instead. I wrote some reference material on MS functions and plugin usage in this Stack Overflow answer.

    Cheers and thanks for the amazing plug :o)

    PS: I see that you still don’t have a retina image in your assets/ folder. Also note that all the plugins’ screenshots can be moved to that folder, so as the make the package lighter for download.

    http://wordpress.org/extend/plugins/wptouch/

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Function compat_is_wordpress_mu does not work as it should’ is closed to new replies.