Support » Plugin: Yet Another Related Posts Plugin (YARPP) » Fulltext Index creation problem – consider titles disabled

  • Resolved Lesia

    (@lesia)


    I’m setting up the plug-in but the message says “Consider Titles” and “Consider Bodies” are currently disabled.
    I ran the command through phpMyAdmin and it said it was executed. But after I pressed the button for “Create fulltext indexes” I get no result.
    Only this message: Fulltext Index creation did not work!
    Trying to force fulltext indexing on your table resulted in an error. Your posts table does not have fulltext indexing capabilities.
    The “consider titles” and “consider bodies” relatedness criteria will remain disabled.

    How can I fix this problem?

    Website: http://taleofthegreat.com

    https://wordpress.org/plugins/yet-another-related-posts-plugin/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author yarpp

    (@jeffparker)

    When you click the “show details” link at the end of the “…currently disabled” line, does it mention what type of database you are using, such as:

    “Unfortunately your table seems to be using the InnoDB engine”

    If your database is using the InnoDB engine, then YARPP cannot consider Titles and Bodies for “relatedness.” You can still use YARPP but it will only use Categories and Tags to compare posts.

    No, it doesn’t say which type of database I use. Is there any way of checking that?

    I checked the type with a command and it does say that the wp_posts table is in MyISAM engine. Where else could the problem lie?

    Plugin Author yarpp

    (@jeffparker)

    Some users who have had the same issue had luck by doing the following:

    1. de-activate plugin
    2. manually delete all yarpp entries in wp_options from phpmyadmin
    3. re-activate plugin

    However, since v4.0.7, deleting the YARPP plugin removes all YARPP data from the database so please first try deleting YARPP (not just deactivating) then reinstalling.

    Let me know if that works, please.

    Wonderful! Deleting and reinstalling worked 😉 Very simple. Thanks!

    Plugin Author yarpp

    (@jeffparker)

    Great to hear!

    This worked for me as well (on a fairly large WP Multisite) – deleting the plugin and reinstalling. Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Fulltext Index creation problem – consider titles disabled’ is closed to new replies.