Support » Alpha/Beta/RC » Fullscreen mode damaged in 4.5-alpha

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    First, if you know your plugin DOESN’T work on 4.5, having the readme say it’s compatible up to 4.5 is incorrect information and you should change that until you fix this 🙂

    What Full Screen mode?

    I don’t see any ‘magnifier glass cursor’ on your example, and your image in the second link throws errors so I can’t check it (you can see it at the top of http://wppa.opajaap.nl/shortcode-reference/ as well…)

    I installed https://wordpress.org/plugins/wp-photo-album-plus/ on a clean 4.5 alpha (4.5-alpha-36168) and there’s no full screen button either so it’s a bit hard to know how to reproduce this.

    Can you provide examples of how someone who has NO experience with your plugin would reproduce this?

    Have you tested with debug on and a clean install of WP?

    Is the full screen a JS trick and, if so, have you watched the console on your browser to see if there are errors?

    Do the following: ( you installed wp-photo-album-plus already ):

    Go to the Photo Albums -> Album Admin page.
    Create an album by clicking on the blue button: Create New Empty Album.

    Go to the Photo Albums -> Upload Photos page.
    Using Box A, select your album and upload at leasst 2 photos to it.

    Go to the Photo Albums -> Settings page.
    Open Table VI ( Links ) by clicking on the banner.
    Open Sub-table B likewise.
    On line 5 ( Slideshow ) under Link Type, select: lightbox.

    Now create a new wp page and enter as content:

    [wppa][/wppa]

    View the page. You will se the ‘cover’ of your album.

    Click the link: Slideshow

    Now hover over the photo, and when you see the magnifier cursor, click. This opens the embedded lightbox feature.

    Now the crux.
    There are two ways to open fullscreen mode, both executing the js function wppaOvlFull(), located in wppa-lightbox.js ( if you delete the wppa-xxx.min.js files on your server, the un-minified versions will be loaded automaticly. )

    method 1: press the f key. ( say yes to the browser that it is allowed to run in fullsize ). You can press the f key again for a total of 3 different fs modes. In a clean installation of version 4.5-alpha-36179 this still works as expected.

    method 2: At the top-right corner of the screen there is a 4-arrow icon that is supposed to toggle fullscreen mode. However, in 4.5-alpha you will now see a mis-formed enlarged version of the ‘standard’ lightbox display. This is the problem, because this works properly on a 4.4 install.

    I have always debug on on my dev sites, i tested it on a clean install of 4.5 nightly build. It is reproducable, reverting to 4.4 fixes it.

    I use Firefox latest on windows 7.

    It looks as if the execution of wppaOvlFull() is hung halfway; there is no re-display what should be there and the keyboard is dead. No js errors on the console.

    About the readme: i just discovered this yesterday. It is impossible to test everything always on every alpha version….

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Sure, but now that you know it’s broken, change the readme right fast 😉 Remember you don’t have to do a full plugin release, just edit the readme in trunk and the tag’d folder and it’ll magically update. Gotta love that. Meanwhile… Since 4.5 isn’t even in ALPHA yet, it’s incredibly premature to tag yourself as compatible. You should always wait until the RC to do that, in case of a late breaking (pun unintended) change.

    Go to the Photo Albums -> Settings page.
    Open Table VI ( Links ) by clicking on the banner.
    Open Sub-table B likewise.
    On line 5 ( Slideshow ) under Link Type, select: lightbox.

    When I did that, I got a popup that gave me debug-bar errors.

    However, once I clicked on the image, pressed f for full screen, I confirmed that works 🙂

    method 2: At the top-right corner of the screen there is a 4-arrow icon that is supposed to toggle fullscreen mode. However, in 4.5-alpha you will now see a mis-formed enlarged version of the ‘standard’ lightbox display. This is the problem, because this works properly on a 4.4 install.

    I don’t know what you think the ‘standard’ lightbox display is but…

    1) https://cloudup.com/cjU8QAYOLRM

    So I have a faded square in a circle, which closes things.

    2) https://cloudup.com/cE-BWTP3l0w

    I have the ‘standard’ full-screen icon, which works when I click on it.

    Thank you!

    I updated the Tested up to

    Meanwhile i localized the issue from being dependant of a setting that may be interfering. So there is a workaround, It may be a timing related issue that i have to investigate on further. I still do not understand why this is dependant of wp 4.5; could be newer version jquery… but i guess i will finally be able to fix it.

    Thank you for your time and effort.

    Topic closed.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    We didn’t bump jquery in WP for 4.5. It was last bumped to 1.11.3 6 months ago.

    https://core.trac.wordpress.org/browser/trunk/src/wp-includes/js/jquery

    You can see them all there 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Fullscreen mode damaged in 4.5-alpha’ is closed to new replies.