Support » Themes and Templates » Full width page

  • Resolved fitnessblogaustria

    (@fitnessblogaustria)


    Hello,
    I’ve addded this piece of code into my child themes custom style.css:

    @import url(“../twentythirteen/style.css”);
    body .site-header {
    }
    .entry-header,
    .entry-content,
    .entry-summary,
    .entry-meta {
    margin: 0 auto;
    max-width: 1600px;
    width: 95%;
    }

    and I’ve copied the page.php and named it full-width-page.php into my child theme folder

    It works perfectly fine and every page is fullwidth. The problem is that also every post is now full with. How do I have to rewrite the code so it only works for pages but not posts?
    (I’m using twenty thirteen)

    Thanks for your help!

Viewing 7 replies - 1 through 7 (of 7 total)
  • janet4now

    (@janet4now)

    still awesome :)

    did you make any changes to the full-width-page.php template? You didn’t mention why you did that.

    can you put a link to your site, please?

    No I didn’t make any other changes to the full-width-page.php file
    here’s the site: http://www.athleticsaustria.at/

    janet4now

    (@janet4now)

    still awesome :)

    You can remove that template from your child theme then, as this is only for modified files.
    You can remove this too from your style sheet as it does nothing:
    body .site-header {
    }

    Now add another style:

    .single .entry-header,
    .single .entry-content,
    .single .entry-summary,
    .single .entry-meta {
    margin: 0 auto;
    max-width: 1600px;
    width: 95%;
    }

    Change the max-width and width to the default settings (check your parent theme style.css) or another width that you want.

    Thank you!!! It works perfectly now!

    Topic resolved

    Thanks for this! I did the same, and it’s worked (www.yarnball.net.au). However it doesn’t display full width on mobile devices. What CSS do I need to change for that? Thanks

    janet4now

    (@janet4now)

    still awesome :)

    .site-header {
    background-color: #00024C;
    background-size: 100% auto !important;
    }

    You’ve modified your footer so it’s no longer responsive. You’ll have to decide what you want to do there.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Full width page’ is closed to new replies.