Support » Theme: OceanWP » full width drop down mega menu background oceanwp

  • mrkapable007

    (@mrkapable007)


    hi kindly , assist how can i make this dropdown megamenu background to be full width, i wouldl like the background to be full width . please please please see the link attached.

    https://imgur.com/a/TfgQTjs

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Amit Singh

    (@apprimit)

    Hello,

    Add the below code to the Customize > Custom CSS section to make it full width.

    ul.megamenu.col-6.sub-menu {
        width: 97vw !important;
    }
    • This reply was modified 1 year ago by Amit Singh.
    johncarteroz

    (@johncarteroz)

    This is what I need also! But I cannot get it to go full width either

    I have inserted the added the css as mentioned above but no luck.

    https://bit.ly/2w7jvNx

    Please please… can someone advise what is stopping this from working? Thanks so much!

    Amit Singh

    (@apprimit)

    Try to use the below code and check it works or not. Have you designed the megamenu properly? Try to follow the documentation here – https://docs.oceanwp.org/article/149-how-to-create-mega-menus

    Use the below code and check it works or not –

    ul.sub-menu {
        max-width: 100vw;
        width: 100vw;
    }
    johncarteroz

    (@johncarteroz)

    Thank you for your very prompt reply!

    I tried that css code and still no change.

    Yes, the document you linked is the document I used when building my mega menu.

    Something is quite strange… I don’t know why but I tried another mega menu plug in and it also would not do the full width.

    I am using elementor and oceanwp…. I am really lost as to why this is not working. I did buy the oceanwp pack but that was over a year ago, so I hope the community here might have an answer or clue where it is going wrong.

    aldrin22

    (@aldrin22)

    hi johncarteroz, here is the tips to fixed that problem
    edit the page and select that section and select layout on layout part make sure the Columns Gap is selected no gap. if you have any question Don’t hesitate to email me. my email address maraldrin89@gmail.com

    • This reply was modified 8 months ago by aldrin22.
    • This reply was modified 8 months ago by aldrin22.
    Amit Singh

    (@apprimit)

    @johncarteroz It is coming from the menu settings because whenever you hover over your megamenu items, you will see opening another dropdown.

    @aldrin22 sharing email or any contact information is not allowed here. Please try to follow the forum guidelines.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘full width drop down mega menu background oceanwp’ is closed to new replies.