WordPress.org

Ready to get started?Download WordPress

Forums

BizStudio Lite
[resolved] Full Width Background Gallery very slow to load (9 posts)

  1. graphics616
    Member
    Posted 1 year ago #

    I am getting complaints that the Full Width Background Gallery is very slow loading. I have saved the images used to web sized images to help load but it does not matter. It seems to be the javascript that is slow, not the images. How do I disable the background gallery and go with a standard single image background that will not load down the page load time?

    I would just use a single image in the background gallery but that does not help either. Every time a person visits a different page on the site it has to load all over again.

    By the way. I do like this theme. If I can fix this problem then I will say perfect!

    Thanks much.

  2. Gunjan Rai kanungo
    Member
    Posted 1 year ago #

    Hi,

    Please send us the URL for your site to sortout the issue. However, in our testings we didn't find any issues regarding slow loading. Still, if you can share the site's URL, we'd be able to take a look at what's causing such issue. Thank you for your patience.

    Best,
    Gunjan

  3. graphics616
    Member
    Posted 1 year ago #

  4. Gunjan Rai kanungo
    Member
    Posted 1 year ago #

    Hi,

    Please use jpg image format or use compress .png file (tinypng).

    You can also use one more theme option for this:
    1) go to Full Width Background Gallery >> DISPLAY SETTINGS >> off .
    2) Bizstudiolite Options >> General Settings >> Custom Background >> select color and upload your background image then select no repeat , top center , fixed in place.
    3) save options.

    Best,
    Gunjan

  5. graphics616
    Member
    Posted 1 year ago #

    I did already used multiple images but decided to go with just one in order to see if that would speed the load time. I also shrunk the size of the images used and that did not help. The delay is still around 15 seconds load time. To me is seems that the javascript is lagging not the size of the images.

    How do I disable the background from working at all so that I can go with a static background image if I choose to do so?

    Thanks for your communication, Gunjan.

  6. graphics616
    Member
    Posted 1 year ago #

    I compressed my image even more. It is very small now. 179KB. That did help a little, but there is still a lag of about 3 seconds on my pages with maps and contact forms. Also I notice that one my Droid Razr phone when I scroll all the way to the top or the bottom of a page, I have the same reloading of the background image.

    Is there a way that I can get this to not happen anymore? I love your theme, but this is not making the owners of the URL happy. Can I change the load order of the javascript or something else to take care of this? And as I stated above, if not, how do I remove the background gallery and go with a static background that is just called by my css?

    Thank Gunjan.

  7. Gunjan Rai kanungo
    Member
    Posted 1 year ago #

    Hi,

    You can also use static image option, for this:
    1) go to WordPress Backend panel >> Appearance >> Full Width Background Gallery >> DISPLAY SETTINGS >> click on On button to Off after that your background gallery option is off.
    2)then go to Appearance >> Bizstudiolite Options >> General Settings >> Custom Background >> select color and upload your static background image then select no repeat , top center , fixed in place.
    3) save options.

    Best,
    Gunjan

  8. graphics616
    Member
    Posted 1 year ago #

    This resolved the issue I was having. I think that another of my plugins was conflicting with the background gallery loading. My particular best option was using your static background option.

    Thanks Gunjan. Great theme. Thanks for your quick responses to my questions. That in itself make a theme a winner to me.

  9. Gunjan Rai kanungo
    Member
    Posted 1 year ago #

    Hi,

    We are happy that your problem would solved.
    Thank you very much for your love and support.

    Best,
    Gunjan

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic