Support » Plugin: Lead info with country for Contact Form 7 » Full URL missing on landing page info

  • Resolved thomasttte

    (@thomasttte)


    Hi there,

    I’ve just implemented your plugin on a number of my sites, and it seems to work great, thanks.
    However, regarding landing page info it does not include the full URL:
    For example, if I land on http://www.mydomain.com/?campaign=123, it only shows http://www.mydomain.com, and not the full URL, which is very important to me.
    Is there a way to fix this?
    I believe it could be fixed using something along $_SERVER[“SERVER_NAME”].$_SERVER[“REQUEST_URI”]

    Thanks.

    Best regards,
    Thomas

Viewing 3 replies - 1 through 3 (of 3 total)
  • Bump bump 🙂

    Plugin Author apasionados

    (@apasionados)

    Hi Thomas,

    On our sites it works correctly. The landing page info is displayed using:
    $_SESSION['LandingPage'] = "http://" . $_SERVER["SERVER_NAME"] . $_SERVER["REQUEST_URI"];

    So it should be displayed correctly. We don’t know why on your server the information is not correct.

    We just noticed that the protocol is always set as http:// and we will add a check for the SSL protocol.

    Best regards from Spain.

    Thanks for your reply. It seems to work fine in Internet Explorer but not Safari.
    Strange.
    Maybe your update will fix it.

    Thanks for your effort and for providing this plugin.

    Cheers,
    Thomas

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Full URL missing on landing page info’ is closed to new replies.