Support » Fixing WordPress » Full Text RSS Does Not Work (WP 2.1.1)

  • Hoping someone can help.

    My site is: http://www.lifeinbeta.net
    My RSS feed is: http://www.lifeinbeta.net/wp-rss2.php

    As you can see, my RSS feed is only displaying a few lines of text. I want it do display FULL-text.

    I’m *not* using the !– more — tag (as you can see on the website), so it shouldn’t cut off because of that.

    Under Options > Reading, I have it set to “Full-Text”.

    I’ve tried setting it to “Summary” and publishing, then switching it back to “Full Text” and publishing again — no luck on that.

    I also tried installing the Full Text Feed plugin (http://cavemonkey50.com/code/full-feed/) and that didn’t help either.

    What am I missing? How can I make my feeds full text again?

Viewing 15 replies - 1 through 15 (of 18 total)
  • therealdrag0

    (@therealdrag0)

    Word to this guys problem.

    Doodlebee

    (@doodlebee)

    What are you using to view your feeds?

    amglori

    (@amglori)

    What are you using to view your feeds?

    I’m using Google’s feed reader (http://reader.google.com)

    But even if I open IE and type in the URL to my feed (http://www.lifeinbeta.net/wp-rss2.php) — to view the XML, the <description> gets cut off after about 3 lines and just has an ellipsis to continue reading.

    Moderator Samuel Wood (Otto)

    (@otto42)

    The description tag always uses the excerpt for some reason.

    Find this code in wp-rss2.php

    <?php if (get_option('rss_use_excerpt')) : ?>
    		<description><![CDATA[<?php the_excerpt_rss() ?>]]></description>
    <?php else : ?>
    		<description><![CDATA[<?php the_excerpt_rss() ?>]]></description>

    Change it to this:

    <?php if (get_option('rss_use_excerpt')) : ?>
    		<description><![CDATA[<?php the_excerpt_rss() ?>]]></description>
    <?php else : ?>
    		<description><![CDATA[<?php the_content_rss() ?>]]></description>

    I do not know why this option has been disabled in this way. I’ll look into it in trac.

    Moderator Samuel Wood (Otto)

    (@otto42)

    Huh. For some reason this was broken 3 years ago and nobody has bothered with it. I’ll submit a patch for it later.

    Xander

    (@xander)

    Mind-boggling.

    amglori

    (@amglori)

    Thanks, Otto42! That solved the problem of displaying the entire post!

    However, now the links in the post don’t work quite right. Instead of displaying as hyperlinked text, they’re referenced at the bottom of the post with numbers contained in brackets (example: http://www.lifeinbeta.net/wp-rss2.php) — any ideas on fixing this?

    Thanks for the help so far!

    Moderator Samuel Wood (Otto)

    (@otto42)

    Try using the_content() instead of the_content_rss(). I’m not sure that function has been updated in a while, so it’s doing this odd summary thing.

    Clearly, some work needs to be done on this section of the codebase.

    amglori

    (@amglori)

    Thanks, Otto42. That seems to work!

    Moderator Samuel Wood (Otto)

    (@otto42)

    Actually, on reflection, that code in wp-rss2.php is fine. The rss_use_excerpt option is basically controlling whether the content:encoded bit is output or not. Okay, it’s an odd way of doing things, but it does work as far as it goes.

    I think that in order to fix this, somebody needs to work out what most readers use when presented with both a description and a content:encoded section. According to the documentation (such as it is), description should not be the full content, it should only be a small thing describing the content.

    Xander

    (@xander)

    From what I know of common implementations some readers still use the description field expecting full entry.

    Currently I have modified my RSS2 feed to drop full content in both description and content:encoded… good/bad idea?

    Doodlebee

    (@doodlebee)

    Otto – thanks for the tip. I’ve been trying to figure this out, myself. I’ve found that some people actually get the full description to show up – but it’s always some kind of fluke, and I can’t find the common thread that makes it happen.

    Xander – if you could tell me how you did that, I would *so* appreciate it. i have several clients who look for this to happen, and (as I said) I can’t figure out how the ones that *have* gotten it to work make it work. I’m giving a presentation on Podcasting and WordPress (PodPress) in a few weeks, and I’d love to add this to the thing I’m doing.

    I couldn’t make that work..

    the line you started with,

    <?php if (get_option(‘rss_use_excerpt’)) : ?>

    starts

    <?php if (get_settings(‘rss_use_excerpt’)) : ?>

    on my rss2.php file

    My Rss Feed:
    http://celebridiot.com/gossip/?feed=rss

    Keeps defaulting back to Summary instead of Full Text. Tried the above fix and also tried a full text plugin with no luck.

    Verison 2.2.1

    When I was running 1.x the full text feed was working fine. I do use the MORE tag, but i don’t care if it cuts there I just want everything that is before that tag to appear.

    Any help is greatly appreciated!

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Full Text RSS Does Not Work (WP 2.1.1)’ is closed to new replies.