WordPress.org

Support

Support » Themes and Templates » Techism » [Resolved] Full text posts on homepage

[Resolved] Full text posts on homepage

  • Sorry for being new. I am in need of some pointers in this theme. I know it is documented all over in other themes how to change the home page posts from excerpt to full text. However I have been unable to figure this out. Any help greatly appreciated.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Create a child theme first http://codex.wordpress.org/Child_Themes

    Then put content.php in your child theme and locate:

    <?php if(is_home() || is_category()): ?>
    <?php the_excerpt( __( 'Continue reading <span class="meta-nav">&rarr;</span>', 'techism' ) ); ?>
    <?php echo '<a class="readmore" href="' . get_permalink() . '" title="'.the_title( '', '', false ).'">'.__( 'Read more', 'attitude' ).'</a>'; ?>
    <?php else: ?>
    <?php the_content(); ?>
    <?php endif; ?>

    replace it with:

    <?php if(is_home() || is_category()): ?>
    <?php the_content(); ?>
    <?php endif; ?>

    Hope this helps!

    Awesome! Thanks, I wasn’t sure if that was the right spot or not. Also trying to find where to remove the icons from posted by section of each post. the little clock and what not.. Been trolling CSS and PHP. .Net guy feeling like a newb here sorry.

    Theme Author Rajeeb Banstola

    @rajeebthegreat

    @jcanlett Sorry for the late reply !

    In the next version release, I will update the theme setting as per your requirement. Hope you could wait few more days 🙂

    Thanks for understanding !

    Yes of course, I am just now starting to understand how this all works. I can wait for that. Great theme.

    Theme Author Rajeeb Banstola

    @rajeebthegreat

    Hello jcanlett,

    New setting has been added Techism version 2.0.4 to enable full texts on homepage. Please do update your theme.

    Thank you !

    @rajeebthegreat

    I’m also a new user of WordPress and I use your theme for over a month now for our new website. I also experience the problem with the full text of posts. This didn’t seem to be the case a few weeks ago.
    I did tick the box
    Customize Homepage layout
    Enable Full Post on Homepage

    but that doesn’t seem to help.
    The ‘Read More’ button wouldn’t be a problem if it would show the full post. It just goes to a new page with the same limited message.
    If you want to check, please see our site http://www.wsvvissershang.nl
    Left toolbar under ‘Laatste nieuws’
    Hope you can help me on this one.

    Theme Author Rajeeb Banstola

    @rajeebthegreat

    Hello Hans Beuving,

    I have fixed that issue and updated the theme. This issue has been fixed in Techism version > 2.0.6 .

    Thanks for using Techism theme !

    Hello Rajeeb,

    Thank you for your reply. I’m still using version 2.0.4 I did remove that version and tried to add the theme again. However, if I do a theme search for Techism I get the same older version 2.0.4 again. How can I get this newer release?

    Thanks for your help

    Theme Author Rajeeb Banstola

    @rajeebthegreat

    Hello Hans Beuving,

    Sorry for the trouble. The updated theme is now available to download. Hope you check that out. 🙂

    Thank you again for understanding and using Techism theme !

    Thank you Rajeeb,

    I’ll check for the update soon.
    Pleasure using your theme.

    Hi Rajeeb,

    Downloaded and installed. Seems to work fine.
    Thanks again

    Theme Author Rajeeb Banstola

    @rajeebthegreat

    Hello Hans Beuving,

    Nice to know that it’s working fine now.
    Thanks for using Techism theme. 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Full text posts on homepage’ is closed to new replies.
Skip to toolbar