Support » Fixing WordPress » Full-Size Images Not showing up but Thumbnails Are

  • Resolved bryanlilly


    I’ve run into a strange image issue that I haven’t found a solution to by reading the threads so far. I’ll see if I can outline the problem:

    1. I upload image.png through the media uploader.
    2. image.png appears fine in the gallery. I attempt to insert image into post or use as featured image.

    3.a. If using the full-sized image, image.png appears broken.
    3.b. If I edit image.php, rotate ccw 90 degrees and then cw 90 degrees for example, and save it, the image appears.Note: this saves the image with a new name. image-e13399…png.

    4.a. If I use the thumbnail or medium version of image.png, the image appears.
    4.b. These images are auto-generated, and named image-100×100.png, etc.
    4.c. If I link these images to the original image.png, clicking on the image brings up a 500 Internal Server Error.

    So, what I’ve gathered so far is that, for whatever reason, links to the original uploaded file do not work. Any changes to that file that result in a new filename, (Example: from image.png to image-100×100.png) allows the new image to be seen.

    Thing’s I’ve tried:

    • Checking to see if images actually upload. They do.
    • Used multiple browsers. Not browser specific
    • Flushed browser cache and w3t plugin cache
    • Switched themes to Twenty Eleven–problem persisted
    • Deactivated all plugins–problem persisted
    • Checked media settings–default upload path, etc.
    • Checked PHP versioning — 5.3.14

    Summary: image.png bad. image[any_other_text_added_by_changing_image].png good.

    This problem occurred after upgrading to 3.4. Upgrading was done by my host.

    I’m at a complete loss as to what’s going on. Any help would be appreciated.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I figured it out. There was a conflict with the web.config file. The site is hosted on an IIS server, which was upgraded so I included the file for permalinks. The server was then downgraded because of a specific issue, and the file caused a conflict.

    I’m not sure why the conflict didn’t surface until the upgrade to WP 3.4, as it was still working fine before. I deleted the file and everything works. Marking resolved.

    Can I ask what is your final <rewrite> as I’m having the same issue.


    i have the same problem here.
    i can upload a new image, that’s work fine but i can not see the full-size img, but thumbnails work fine.
    please help…

    i have fixed this problem

    maybe: temp folder did not have permision for User to modify other folder.

    i added Permision (modified) for User to C:window:temp folder (at server )

    and it’s worked for me.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Full-Size Images Not showing up but Thumbnails Are’ is closed to new replies.