Support » Plugin: Image Widget » Full Size image always defaults to thumbnail

  • Resolved Stacy Kvernmo

    (@funstacy)



    Every time I select one of my full size images (which is only 235px x 74px), insert it to the image widget, then hit save the image changes from the full size to the thumbnail. When I check firebug it is actually pulling the url of thumbnail too and just using my height and width attributes as max-height and max-width.

    Somehow I finally got it to work correctly on my test site, but now I can’t figure it on the live site. I moved all my files over too. This is so weird.

    UPDATE: if I add an image with the “external media” tab it works as expected. I just can’t upload a new one or go through the media library.

    http://wordpress.org/extend/plugins/image-widget/

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’ve had the same problem.
    Uncheck media settings > “Crop thumbnail to exact dimensions”

    I have the same problem. Unchecking the “Crop thumbnail to exact dimensions” box does not help.

    If I choose change image and choose an image from the media library, choose actual size and then insert into widget then the image appears to be right when first inserted. As soon as I click Save for the widget the image is cropped on its height but not width. It seems to be cropped to 190px – I’m not sure where that is coming from since my thuimbnail size is 150×150.

    The HTML for the image, after inserting and before saving is (according to Firsbug)

    <br />
    <img width="240" height="269" class="aligncenter size-full wp-image-13425" alt="" src="http://birka.recdev.adamc-ubuntu.cybertron.local/files/2013/06/taxfreekatalog-janmar2013_240.jpg"><br />

    After saving the html becomes

    <br />
    <img width="240" height="190" style="max-width: 240px;max-height: 269px;" alt="taxfreekatalog-janmar2013_240" class="attachment-240x269 aligncenter" src="http://birka.recdev.adamc-ubuntu.cybertron.local/files/2013/06/taxfreekatalog-janmar2013_240-240x190.jpg"><br />

    240×269 is the right dimensions for the full-sized image, but what I get is a 240×190 cropped image. I’m not sure where the 190 comes from.

    I’d rate this as a fairly urgent bugg – at the moment we cannot create or edit image widgets which don’t look crap because of this bug.

    Edit: Should have said: I’m running WP 3.5.1 and ImageWidget 4.0.7. I’m running in network mode (not that I think it makes any difference). i do have two other plugins installed which can affect image handling: NextGEn gallery and Easy Fancybox, but this problem happens when I upload an image or choose it from the ordinary media library so i don’t think they are related. Also, the problem seems to be not when the image is inserted into the widget but when the widget is then saved. We have run with both these plugins quite a while and the image widget used to work. i think (but cannot be 100% certain) that it was in connection with the upgrade to 3.5.1 that the problem came.

    This excellent plugin has served me very well.. until the update!

    Please find my site at seethruresearch.com – I won’t be keeping it up in this broken state for long, so please help asap.

    I am using Image Widget in two instances. On the sidebar it works fine. The problem occurs in the footer widget area.

    Although I specify the custom size (940×141), it shrinks the image to 220×33 when I preview the site. You can see for yourself by using Firebug.

    I urgently need some help with this, as my site is effectively broken – critical information is contained in the footer.

    FYI I’m using twenty-ten with the latest version of WordPress with no other image plugins – except slideshow.

    A donation to your favourite charity is waiting for the genius who can resolve my problem and get my new business launch back on track!

    Please help!

    Plugin Author Peter Chester

    (@peterchester)

    @seethru_dave, your note is really something that belongs in it’s own ticket, but i’ll give it a shot all the same…

    There are 2 ways to fix this. 1. Fix the CSS. or 2. Bypass the image widget CSS.

    1. Fix the CSS:

    Using Chrome inspector, I see that you have the following CSS applied to the parent div in your html:

    #footer-widget-area .widget-area {
    float: left;
    margin-right: 20px;
    width: 220px;
    }

    That is telling the parent to be 220px wide. The image widget has CSS that applies a max-width of 100%. 100% of 220 is 220. If you increase this width in your CSS (and any other divs that are constraining the widget) then your problem will be fixed and your site will be more robust since it won’t have conflicting CSS.

    #footer-widget-area .widget-area {
    clear: both;
    margin: 0px;
    width: 940px;
    }

    2. Override the image widget

    Alternatively (though not as ideal as the previous fix) you could override the max-width of the image widget. Add the following to your functions.php file in your theme and the image will no longer use a max-width parameter:

    <?php add_filter('image_widget_image_maxwidth', '__return_null'); ?>

    I couldn’t sleep… until I checked my phone and saw you had replied…

    Thank you SO much for your quick and considered reply, Peter.

    I went for fix #1 – and it worked a charm.

    Please be in touch regarding your favourite charity!

    This developer rocks!

    Plugin Author Peter Chester

    (@peterchester)

    Thanks @seethru_dave!

    One thing that always makes my day is a favorable rating 🙂
    (click the stars on the plugin page to rate: http://wordpress.org/plugins/image-widget/)

    As for charities, I love that suggestion. Given the context of this, how about the wordpress foundation. http://wordpressfoundation.org/donate/

    Thanks!

    Achievement unlocked! Reviewed and donated on behalf of Modern Tribe.

    Thanks again Peter, and keep up the excellent work!

    Plugin Author Peter Chester

    (@peterchester)

    Awesome!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Full Size image always defaults to thumbnail’ is closed to new replies.