Support » Plugin: Give - Donation Plugin and Fundraising Platform » Full form showing when set to reveal

  • Hi! I have a Give form on a client’s site that is set to Reveal. It was working great but now the full form is showing all the time. I tried disabling other plugins to see if it was a conflict with something, and I tried recreating the form and I’m having the same issue with that one as well. The problem seems to have started with the most recent update. Can you point me in the right direction to fix this?

    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Devin Walker

    (@dlocc)

    Hi @torlowski – We sure can! Can you provide a link to your donation form so we can see the issue first hand?

    Sorry for the delay. I had temporarily solved it by rolling back to a previous plugin version from a backup. So I made a staging site with the update for you to look at. You can see the form in the sidebar and at the bottom of this posts -http://beta.downstream.city/news/p4-interview-scott-bricker/.

    The live site with the previous version currently active is visible at http://downstream.city/news/p4-interview-scott-bricker/ for comparison purposes.

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Hi @torlowski since this issue seems connected to updating to Give version 1.8.5, most likely what happened is you didn’t see the Admin notice asking to trigger the database update. Here’s what you can do on the beta site:

    1) Make sure that you update to Give 1.8.5 first.

    2) Login to the site, and in the Dashboard, or the Plugins screen, you should see a notice at the top of the screen asking you to click a link to update your Give database. Click on that and all should then be fine.

    3) If you don’t see that notice, then (after you’re on 1.8.5 and logged into the site) navigate directly to this page:
    http://beta.downstream.city/wp-admin/index.php?page=give-upgrades&give-upgrade=give_v18_upgrades_form_metadata

    After the upgrade routine is finished you should be fine.

    Let me know how that goes. Thanks!

    Matt,

    Unfortunately that didn’t do the trick. There was no admin notice about the database update, and I went to the direct URL that you gave, which did trigger the update, but the forms are still showing full.

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    OK, from the looks of your form it might be a setting that got bumped on accident. Go to “Donations > Settings > Display Options” then make sure that “Default Give Styles” is set to “Enabled”.

    Yes, it is set to Enabled.

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Hmmm… well the problem is that our styles are not being output on that page anywhere. Do you have a caching plugin? Can you clear your cache and then deactivate it just for testing? Do you have other plugins that are meant to handle scripts on your page in any way?

    Gah. Seriously. I swear I clear hosting cache like three times. Maybe it was because the db hadn’t been updated when I did that? It’s working fine on the beta site. Will do a final test on the production site before I mark this as resolved.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Full form showing when set to reveal’ is closed to new replies.