• Resolved weipah

    (@weipah)


    Since this year the ftp-upload is not working anymore.
    I validated that it is still possible to upload with same ftp-settings and credentials in another client. Manually invoking upload in plugin seems to look fine, but file is not present on the server.

    Here is the log file I get. Plugin says everything was fine, but the file is not created. I even checked with root access directly on shell.

    Plugin version is 1.14.10

    [2021-01-13 13:20:00 UTC] Completed Boldgrid_Backup_Admin_Ftp::upload!
    [2021-01-13 13:34:53 UTC] Cannot add signal handlers, pcntl_async_signals function does not exist.
    [2021-01-13 13:34:53 UTC] ——————————————————————————–
    [2021-01-13 13:34:53 UTC] Beginning Boldgrid_Backup_Admin_Ftp::upload…
    [2021-01-13 13:34:53 UTC] Local path: /var/www/pb-prod/wp-content/boldgrid_backup_ffE7sCX9BMFZ/boldgrid-backup-xyz.com-26708e2c-20210113-133322.zip / 850227980
    [2021-01-13 13:34:53 UTC] Remote path: Backup-peakboard/boldgrid-backup-xyz.com-26708e2c-20210113-133322.zip
    [2021-01-13 13:34:53 UTC] Connecting…
    [2021-01-13 13:34:53 UTC] Logging in…
    [2021-01-13 13:34:53 UTC] Beginning upload…
    [2021-01-13 13:35:32 UTC] Upload status: 1
    [2021-01-13 13:35:32 UTC] Enforcing retention…
    [2021-01-13 13:35:32 UTC] Retention enforcement complete!
    [2021-01-13 13:35:32 UTC] Getting remote contents…
    [2021-01-13 13:35:32 UTC] Remote contents: Array
    (
    [0] => drwx–x— 2 716829 nobody 4096 Jan 13 14:35 .
    [1] => drwxr-xr-x 6 716829 nobody 4096 Nov 27 16:43 ..
    [2] => -rwxr—– 1 716829 nobody 622201107 Jul 30 02:05 backwpup_CTTZ7Y2U06_xyz_2020-07-30_03-00-03.zip
    [3] => -rwxr—– 1 716829 nobody 847178524 Dec 29 03:01 boldgrid-backup-xyz.com-26708e2c-20201229-020005.zip
    [4] => -rwxr—– 1 716829 nobody 847387169 Dec 30 03:01 boldgrid-backup-xyz.com-26708e2c-20201230-020005.zip
    [5] => -rwxr—– 1 716829 nobody 847338276 Dec 31 03:01 boldgrid-backup-xyz.com-26708e2c-20201231-020006.zip
    )

    [2021-01-13 13:35:32 UTC] Completed Boldgrid_Backup_Admin_Ftp::upload!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Jesse Owens

    (@jessecowens)

    Hi @weipah

    Thanks for the interesting question, we’ll be happy to help you troubleshoot.

    Looking at the log file, I can only speculate that somehow your newly uploaded backup is being deleted for retention enforcement, rather than you backup files from last year.

    One way we can test this theory is for you to increase your retention setting to 4, and examining the log from that upload to see if that file remains on your remote server. Navigate to Total Upkeep > Settings > Backup Storage and click Configure FTP/SFTP, and you’ll find the retention setting, which from this log I believe is currently set to 3.

    Alternatively, you can manually delete your backup from Dec 29 from the shell if your remote server has a disk space limitation.

    Also, it might help to check the date on your remote server. When you log into the shell, run the command date to make sure that the date is correct since the new year.

    I’ve also created a Feature Request to add some more detailed information to the retention enforcement in the log.

    Thread Starter weipah

    (@weipah)

    Hi Jesse,

    thanks for your hint. It was the retention setting. Increasing by one was successfull. It seem the very old file in folder with another filename was also considered by the upload.

    Thanks again!

    Plugin Support Jesse Owens

    (@jessecowens)

    Hi @weipah

    Hopefully that does the trick, but I’m concerned the next scheduled backup might fail to upload if the retention settings aren’t recognizing which file is the oldest one. Let us know after your next backup if the same thing happens.

    Plugin Support Jesse Owens

    (@jessecowens)

    Hello-

    It’s been about a week since we heard back from you about this, so I’m going to go ahead and mark the topic as Resolved. Please let us know if you have any more trouble, we’re happy to help!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.