Support » Fixing WordPress » ftp plugins and permissions gone awry

  • Help…yes they all say that. I am an experienced WordPress user but can’t fathom this.

    I uploaded (ftp) about 7 plugins used on another site to a wordpress installation and instantly the permissions for the wordpress installation went wrong, plugins telling me they wouldn’t work unless x or y directory was chmod to 755 or above when they already were. Inability to chmod directories recursively.

    And now deleting or installing plugins within wordpress means I have to keep putting in my ftp details and pass

    I have no idea what to do to get permissions working again

Viewing 6 replies - 1 through 6 (of 6 total)
  • The problem is with the ownership of the files, not the permissions: your files need to be owned by the same username that WordPress runs under. When you add plugins or themes directly through the admin interface, the user is set automatically. However, since you uploaded via FTP, they’re probably marked with the username you use to log in to FTP, which often isn’t the same.

    (And sorry I can’t be more specific about the username you need: on most servers, that user is the webserver itself, but some hosts configure things differently.)

    Ok I understand that but why would it then effect the way everything now sees wp content as having the wrong permissions

    some have owner: “ftp login name” group:99

    some have owner:ftploginname group: ftploginname

    looking at other wordpress installations it would seem that the ftploginname for owner and group is the norm

    However I have tried a few ftp clients and cant change it. cpanel maybe ?



    I’m having the same issue. My permissions have completely screwed up on my site and I can’t fix it at all.. I’ve tried fixing them manually in FTPZilla.. Any suggestions?

    jonathan s


    I went to my web host and got them to change all back to the default settings and this mainly fixed it. I had to do a little manual tweaking also on chmod for ownership as Amy suggests



    Thanks for that, I fixed it now. Check my site, should be working:

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘ftp plugins and permissions gone awry’ is closed to new replies.