Support » Fixing WordPress » FTP needed or not for local upload

  • Do I need FTP to install a theme and its associated Plugin onto WordPress that is installed locally on my computer? I have tried to upload a Theme that I purchased and the WP Dashboard asks me for my FTP credentials.
    I am simply trying to install a Theme and a plugin on to my locally installed WP. I know I will have to use an FTP when I upload my files onto my hosting servers. But do I need FTP to properly install purchased themes and plugins? If not how do I do that.
    Thank you in advance.

Viewing 15 replies - 1 through 15 (of 20 total)
  • No. If you have local access, just go to the WordPress folder, locate wp-content folder and locate the themes directory. Then just copy the theme folder you want to install inside of it. Then back on the WordPress admin side, it should show up as a theme you can enable/disable.

    Same thing for plugins – just go to the local WordPress folder and upload/copy the plugin folder you want to install to your wp-content/plugins folder. Then back inside the WordPress admin screens, the new plugin should show up under plugins, where you can then enable it.

    Thank you for your reply,
    I tried doing this and I get “Access Denied”
    I tried under the /var/www/ and /usr/share/ as well in both wp-contant/themes. No luck.

    Any advice?

    Check your permissions. Right-click on the wp-content folder and see if your user account has read/write permissions.

    I do NOT have permission to Read/Write. Only Access. I went up the chain of files and cannot change anything. It says I am not the owner. I own the computer and the business.
    I appreciate your tenacity in helping me.

    I am running Ubuntu 13.10

    Okay then that means the web server application is likely the owner (this is good security practice anyway) so what you need to do is add your user account into the Group, or, even better, temporarily give your user account super-admin privileges (sudo). As this is a bit beyond WordPress, I suggest you read up on how Linux (and all *Nix operating systems) handles users, groups and permissions. This is important to understand at least on a general level as it impacts the security of your system.

    Thank you. I am looking into this as I finish this posting. I appreciate your help.

    I have been able to move the the Theme file, I purchased to its new location in /usr/share/wordpress/wp-content/themes. However I can not access the theme file itself through my WordPress Dashboard/Theme.
    I used the chmod 755 on the file. I can open the file and see its contents but unable to open the file in Dashboard.

    Can you open any themes via the dashboard?

    I can only open the themes it came with. I cannot access the theme I purchased and installed into the wp-content/Themes folders in VAR, SRV and USR.
    I can see the folder. I can open it but I cannot access the folder throught the Dashboard to customize.

    What theme is it? Is the folder unzipped?

    I cannot access the theme I purchased

    It could be an issue in the theme. Have you spoken to the theme’s vendor about this?

    Irex standard. I unzipped it as any other zip file. I then took the Irex theme file and installed it into the wp-content/Themes folders.

    Try downloading a theme from here (WordPress.ORG) and then adding it the same way – see if it works.

    Have you checked that the theme is not inside nested folders?

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘FTP needed or not for local upload’ is closed to new replies.