• Resolved Gustavo Troisi

    (@gustavotroisi)


    Hello,

    I updated to last version in two sites in different hosts, both of them presented this error when trying to add or edit a ftp account:

    Failed to add FTP storage. It can be because the FTP folder permissions are insufficient, or calling PHP ftp_put function of your web server failed. Please make sure the folder has write permission and the ftp_put function works properly.

    Older versions worked perfectly and nothing changed in servers configuration as far as I know.

    Many thanks
    Gustavo

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Support tonyrobins

    (@tonyrobins)

    Hello @gustavotroisi

    It is recommended that you check the following settings:

    1. Make sure the target folder on the FTP has write permission.
    2. Make sure the PHP ftp_put function is installed and working properly on the servers.
    3. Make sure the FTP server is not blocking your website servers.

    All the best,

    Thread Starter Gustavo Troisi

    (@gustavotroisi)

    Hello @tonyrobins,

    FTP server permissions were not changed, that problem is discarted.
    The problem appears when trying to “create” a new ftp connection, or even “edit” an existing one, the saved information of that server is not shown, so I supponse the problem may be other. Please let me know if you can test this on your side.

    Regards,
    Gustavo

    Plugin Support tonyrobins

    (@tonyrobins)

    Hi @gustavotroisi

    Thanks for your update.

    We are going to test it on our side.

    All the best,

    Plugin Support tonyrobins

    (@tonyrobins)

    Hi @gustavotroisi

    We tested it on our sites and with the latest version of the plugin, adding a new FTP storage or editing an existing one works properly. Also, there is no change made to the FTP or other cloud storage in the latest version.

    So, we don’t think it’s related to the plugin updates, you can verify it by rolling back the plugin to an old version and see if it works.

    If the old version does not work as well, then can you send us a debug zip to contact(at)wpvivid.com to help troubleshoot the issue? You can download the debug zip from the plugin’s Debug tab. And please include the url of this thread when you send it so we can track all the information posted here.

    All the best,

    I Have the latest updated version of this plugin but I am getting the error
    https://prnt.sc/-EtSC826_blN

    Plugin Support tonyrobins

    (@tonyrobins)

    Hello @ashokkumawatasm

    Please first check the following settings as suggested earlier in this thread:

    1. Make sure the target folder on the FTP has write permission.
    2. Make sure the PHP ftp_put function is installed and working properly on the servers.
    3. Make sure the FTP server is not blocking your website servers.`

    If that does not solve the issue, then can you send us a debug zip to contact(at)wpvivid.com to help troubleshoot the issue? You can download the debug zip from the plugin’s Debug tab. And please include the url of this thread when you send it so we can track all the information posted here.

    All the best,

    Thread Starter Gustavo Troisi

    (@gustavotroisi)

    Hello,
    I tested version 0.9.48 and it works ok. This version let me edit an existing ftp account or edit, without any problem.
    Really don’t know what the problem could be.
    Regards,
    Gustavo

    Plugin Support tonyrobins

    (@tonyrobins)

    Hi @gustavotroisi

    Thanks for your update.

    Are you sure it’s version 0.9.48 that works, on the same website and same FTP? Since the latest version is 0.9.79.

    All the best,

    Thread Starter Gustavo Troisi

    (@gustavotroisi)

    Absolutely, version 0.9.48 works right but 0.9.79 doesn’t, at least in my cases.
    I tested in 3 sites hosted in diffetent servers. Two using WordPress version 5.7.8 and one 5.8.6

    Plugin Support tonyrobins

    (@tonyrobins)

    Hi @gustavotroisi

    Thanks for your update. We are going to take a look at that.

    All the best,

    Plugin Support tonyrobins

    (@tonyrobins)

    Hi @gustavotroisi

    We compared the two versions and there was no major change regarding FTP.

    So, again, can you send us a debug zip of one or two of the sites to contact(at)wpvivid.com to help troubleshoot the issue? You can download the debug zip from the plugin’s Debug tab. And please include the url of this thread when you send it so we can track all the information posted here.

    All the best,

    Thread Starter Gustavo Troisi

    (@gustavotroisi)

    Done! thank you

    Plugin Support tonyrobins

    (@tonyrobins)

    Hello @gustavotroisi

    Please try the latest version of the plugin – 0.9.80 and see whether the issue is solved.

    All the best,

    Plugin Support tonyrobins

    (@tonyrobins)

    Hello,

    Since we haven’t heard from you for a while, I am going to mark the thread as resolved.

    Please feel free to start a new one if you need any further assistance.

    All the best,

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘FTP folder permissions are insufficient’ is closed to new replies.