Support » Fixing WordPress » FTP blank page again

  • Resolved brownowl


    I’ve searched and searched these forums and the net, and can’t find a solution to this one. It’s been driving me crazy for more than 2 weeks now… First, details:

    Gentoo server: kernel2.6.34-gentoo-r12
    WordPress: 3.0.3
    PHP: 5.3.3-pl1-gentoo
    MySQL: 5.1.51-log
    WebServer: Apache 2.2.16
    vsftpd: 2.3.2

    What happens is that whenever I try to ftp anything for an auto-upgrade, WP accepts the FTP credentials (the ftp log shows a successful login), but the screen then goes blank. There are no errors in any log (syslog, php or apache2), it’s just blank. Everything else works as one would expect.

    This is on a new server, the only WP instance on it, and all plug-ins disabled (askismet).

    I’ve tried adding the ftp credentials to the config file, but all that does is take me straight to the blank page!

    I have also enabled debug in the config file, but nothing is ever reported.

    PHP memory limit has been set to 256M.

    I’ve been working around this by copying files up manually, but now I have a need to host a shopperpress site, and this renders it unusable. It’s become urgent…

    This seems to have happened after a gentoo upgrade somewhere recently, but I’m not sure what it was. All these symptoms are exhibited on my other gentoo servers as well, so I set this up as a latest-and-greatest clean install to try to tie this down: it’s totally virgin.

    I suspect that it’s probably not a WP problem per se, rather a server config one, but I have no problems in any other applications, and I’d really like some help with it please.

    php info at:

    Cheers, Laurie.

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’ve continued to work on this, and have made the following discoveries:

    1) it isn’t an xml issue with Gentoo use flags
    2) if I view source in Firefox, the page source is there, but the display is blank.

    Help still desperately required please!

    Have made some further discoveries:

    1) on trying to delete files for a plug-ins or new theme, after entering the ftp details, the entire screen goes blank, and there is no source to be seen

    2) on trying to add a plug-in or a theme, the left-side menu and the top of the screen remain, but the main panel is blank. The source confirms this, giving an incomplete page.

    Cheers, Laurie.

    Hi, that is a strange problem. You said that all the plugins are disabled and the theme is TwentyTen – this is good since it’s the first thing I would try. Memory seems good (phpinfo() shows 128M) no errors in the logs….

    First things first – 3.0.3 had a serious security issue and you should upgrade to 3.0.4 ASAP. I would download 3.0.4 from, and FTP up the files (rather than trying to upgrade from your dashboard which will probably fail).

    This is exactly what happens when I’ve been messing around with the WordPress core files and make a programming mistake, so maybe one of the WordPress core files got corrupted – in this case doing what I mentioned above should overwrite them with a good version.

    Thanks for the reply.

    I can confirm that there are no active plugins, and only the default theme. I have also just upgraded to 3.0.4 by means of a totally new install from scratch.

    I can also confirm that I haven’t touched any of the WP files.

    Lastly, sadly, I can confirm that the error is still there.

    I have a sneaking suspicion that it’s something to do with PHP, but I don’t know what… I think maybe a recent Gentoo upgrade broke something, and maybe there’s some functionality I need in PHP that isn’t compiled in by default any more…

    Cheers, Laurie.

    I remember using Gentoo back in the day… awesome that everything is compiled from source, until something goes wrong…
    I do agree it’s probably something wrong with PHP. I checked the Gentoo forums (my id from 2003 still works!) and found a couple of things:

    This person is having the same problem as you (fixed)
    Some php issues – not exactly related but maybe some hints here.

    Sorry I can’t be of too much more help, but you might want to post this question on the Gentoo forums too… I remember them being quite friendly and helpful over there.

    Ok, panic over. This is, as I suspected, a Gentoo problem, and it seems caused entirely by the recent upgrade to PHP 5.3.

    I re-emerged PHP with the following USE flags set:

    USE=”cli cgi apache2 ctype fastbuild force-cgi-redirect ftp gd hash iconv ipv6 memlimit mysql nls pcre pic posix pdo reflection session simplexml soap sockets spl ssl tokenizer truetype xml xmlreader xmlwriter xsl zlib” emerge php

    and it works.

    I got the above from this page, which might help someone else on Gentoo with this problem:

    Thanks for the help. I’d tried the Gentoo forums (but not posting), and found a few clues, which led me to find the problem. Gentoo is an excellent distro, we’ve been using it for 10 years, and luckily nothing much goes wrong with it. But when it does, it can be a nightmare. Luckily, this wasn’t too big a deal in the end…

    It has taken a looooong time to sort this one out!

    Cheers, Laurie.

    I was getting this problem on Arch Linux too. I had to uncomment in /etc/php/php.ini

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘FTP blank page again’ is closed to new replies.