Support » Plugin: UpdraftPlus WordPress Backup Plugin » FTP backup connects but can’t create files..??

  • Resolved angelleye

    (@angelleye)


    I have this plugin installed on multiple sites, each configured to backup to a local FTP server I have here. Initially all sites were working just fine. For some reason now I have one site that returns an error now, that it can connect to FTP but can’t create a file in the given directory.

    The exact same configuration still works fine from other sites, though, with the same folder being used, so I’m not sure why this one site would suddenly be failing..??

    When I hit the test button I get this:

    FTP Test Fail

    Here is the latest log file: https://pastebin.com/GrPGp4VZ

    Again, the exact same configuration into the exact same folder works just fine from my other sites, and it worked just fine from this site up until about a week ago.

    Any information on what could be going on here would be greatly appreciated. Thanks!

    • This topic was modified 2 years ago by  angelleye.
Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    Please could you (or your FTP server admin) check that the FTP ports are open, and the firewall ports are not blocked for passive connections.

    Best Wishes,
    David N

    angelleye

    (@angelleye)

    Yes, that’s been checked. Again, the same exact settings are working from other sites. Just not from this one site.

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    Could you (or your hosts/server admin) also check that the connection is not being blocked by the outgoing firewalls on the webserver?

    angelleye

    (@angelleye)

    I’ll check, but if that was the case the connection fail outright wouldn’t it? The error says it’s successfully logged in but is not able to create a file.

    So that leads me to believe the problem would be on the FTP server end, however, the same exact configuration uploading to the same FTP server into the same folder works from other sites, so that leads me back to a site/server specific problem.

    I’ll check the outgoing firewall, but wouldn’t that trigger a flat out “failed connection” error instead of the message it’s giving me now?

    Plugin Author David Anderson

    (@davidanderson)

    but wouldn’t that trigger a flat out “failed connection” error instead of the message it’s giving me now?

    No – the FTP protocol involves multiple connections, and the above message is what you get when the control channel connection gets through, but the data channel connection does not.

    Okay, but I still don’t see why the same exact credentials and directory location work from all my other servers and just not this one. It also worked fine from this one originally. Very strange.

    Hey!

    You solved this puzzle? I’m experiencing the same thing.

    @ctjernqvist, No I have not solved this. It’s still working perfectly from every site except for this one, even with the same credentials and directory location, etc. Very strange.

    @angelleye I found my own error. I received the message that the plugin could login, but not transfer file. I had written the full linux path to the directory ( /home/user/something/something_else/ ) instead of just something/something_else since /home/user was FTP-root for the user.

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi @angelleye,

    Apologies for the delay.

    It is possible that the FTP server firewall has flagged the specific port and server of this site to be blocked.

    @dnutbourne,

    Thanks for the response. The FTP server is a NAS unit with built in FTP. It’s very basic and doesn’t have any sort of firewalls or anything built into it. It’s just “Allow FTP” or don’t.

    I’ve checked my router firewall, too, which is also pretty basic. It has the port forwarding rules and that’s still just fine and working from all other connections I make to it.

    I’ll keep digging and see if there’s something I’ve missed, but I’m really not sure what else to check at this point.

    What about another ftp? Do you have possibility to try another? If not, send me an email at chrille.hedberg@lenom.nu and I’ll hook you up! 🙂

    Yes, I’ve tried other FTP servers, too, and I’m getting the same problem on each of them, but only from this one site.

    I’m working with the hosting company of this site to try and figure out what’s going on here. Seems like it has to be something on their end.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘FTP backup connects but can’t create files..??’ is closed to new replies.