Support » Plugin: Genesis Simple Edits » Frustrating

  • ruben

    (@dispuutfabras)


    After installing I have to update the plugin to get it running.

    “Please install and activate the latest version of Genesis to use this plugin.”

    To update I need to make an new account at the website of Studiopress to get this done.
    When I try to make a new account by clicking “Get started” at Studiopress.com I got on the homepage and have to figure it out myself. The button “My Studiopress” would be logical, but this brings me to the same page as before.

    After one hour trying I’m unhappy and done with this plugin.

Viewing 1 replies (of 1 total)
  • The message says you don’t have the Genesis Framework installed — i.e. your site is not using a StudioPress theme.

    The plugin only works with child themes of the Genesis Framework (created by StudioPress.com). The description doesn’t make that very clear, but it does say it. Genesis Framework is a purchased product — currently $60 USD or you can purchase a theme from StudioPress and the Framework is included.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this review.