Support » Plugin: Wordfence Security - Firewall & Malware Scan » Frozen Admin Login Page

  • Resolved trobaz

    (@trobaz)


    I have to rename the Wordfence plugin in order to login to the backend of my WooCommerce store. The page is unresponsive if I do not rename the plugin. Any suggestions?

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • I have had a call today from a customer who’s having the same problem, traced back to the WordFence plugin. Getting the following error in the logs:

    
    [19-Jun-2020 13:51:10 UTC] PHP Fatal error:  Uncaught Error: Call to undefined method wfWAFWordPressRequest::getRawBody() in /var/www/web/wp-content/plugins/wordfence/lib/wordfenceClass.php:1123
    Stack trace:
    #0 /var/www/web/wp-content/plugins/wordfence/lib/wordfenceClass.php(1764): wordfence::initProtection()
    #1 /var/www/web/wp-includes/class-wp-hook.php(287): wordfence::veryFirstAction('')
    #2 /var/www/web/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array)
    #3 /var/www/web/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
    #4 /var/www/web/wp-settings.php(403): do_action('plugins_loaded')
    #5 /var/www/web/wp-config.php(108): require_once('/var/www/web/wp...')
    #6 /var/www/web/wp-load.php(37): require_once('/var/www/web/wp...')
    #7 /var/www/web/wp-blog-header.php(13): require_once('/var/www/web/wp...')
    #8 /var/www/web/index.php(17): require('/var/www/web/wp...')
    #9 {main}
      thrown in /var/www/web/wp-content/plugins/wordfence/lib/wordfenceClass.php on line 1123
    

    This customer is running their site on 3rd party hosting. Strangely though, I’m not seeing this issue on any other customer websites within our own hosting environment. I’m in the process of downloading a copy of their site to see if I can debug the issue locally.

    WFGerroald

    (@wfgerald)

    Hey @trobaz,

    Can you please try switching the Firewall into Learning Mode and let me know if it helps?

    https://www.wordfence.com/help/firewall/learning-mode/

    @squelch – I’m not sure if these are the same issues or not. Have you had a chance to disable all other plugins to see if it helps? If not, please open a separate thread and let us know how you’re debugging has went, and what steps you’ve taken.

    Thanks,

    Gerroald

    Matt Lowe

    (@squelch)

    My point was that it looks like it’s something environmental causing the issue, as I can’t replicate the same issue anywhere other than on a Namesco server. The customer isn’t paying me to debug the issue, they just wanted their site back online, which I already completed. Adding an extra 1-2 hours onto the bill to debug WHY Wordfence doesn’t work on a Namesco server would have resulted in an unhappy customer.

    trobaz

    (@trobaz)

    @wfgerald switching to Learning Mode did not help.

    WFGerroald

    (@wfgerald)

    Hey @trobaz,

    Do you see any errors in the browser console? If so, can you please share a screenshot?

    https://www.wordfence.com/help/advanced/troubleshooting/#how-to-inspect-the-browser-console

    There might be a conflict either with the theme or one of the plugins you’re using, could you try temporarily switching to a default theme if you’re not already using one and disabling all other plugins then reactivating them one by one to see if the issue persists?

    @squelch – I understand, and do apologize for the trouble. It may be a configuration on the server versus the hosting company itself. Thanks for sharing the information, I’ll make note of it in case I see this in the future.

    Thanks,

    Gerroald

    trobaz

    (@trobaz)

    @wfgerald I do see errors in the browser console. I deactivated 2 plugins listed in the error messages, still the same problem. WordFence is one of the first plugins I install, so if it were the theme, I would’ve seen this issue long ago.

    My concern though is, if there is indeed another plugin conflict, why should I have to disable that plugin? Disabling WordFence fixes the issue, so isn’t the WordFence plugin the problem?

    WFGerroald

    (@wfgerald)

    Hey @trobaz,

    Can you please share a screenshot of the errors you see?

    Did you disable all plugins to check for the conflict, or just the two you noticed in the errors? If you haven’t disabled all of them can you please give it a try?

    Regarding the theme, are you aware of any recent updates?

    When conflicts happen it means for whatever reason there’s code that isn’t compatible. If disabling Wordfence resolves it, it doesn’t necessarily mean it’s the culprit, though we’ll definitely look thoroughly to see if it is. If so, we’ll address it.

    With that said, we have may users using WooCommerce and Wordfence without any issues. So this is likely going to be specific to your environment.

    Please let me know what you find.

    Thanks,

    Gerroald

    • This reply was modified 3 months ago by WFGerroald.
Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.