Support » Plugin: Ultimate Member - User Profile & Membership Plugin » Frontend Profile: 1. Custom fields not showing 2. where to edit profile

  • Resolved bizfundi

    (@bizfundi)


    Hi
    Summary:

    I need to know:

    1. How to get all custom fields to show
    2. What a member must do to be able to edit profile on user page
    3. How to remove that option on users profile icons to edit posts

    CUSTOM FIELDS:

    I’ve added custom fields to default profile form, but only a few show up on the front end user page.

    MY ENVIRONMENT:

    Latest WordPress
    Latest UM
    All plugins deactivated
    My preferred theme disabled
    Using 2015 THEME

    DESCRIPTION:

    i Tried changing the following in settings:

    CURRENT URL METHOD:

    Tried both options, same result
    Current URL Method

    NETWORK PERMALINK STRUCTURE

    Tried both options, same result.
    Permalink

    THE FORM SETUP:

    I added fields to the default form.

    Each field is setup with Visibility to everyone, and privacy to profile owner and admins:
    Form Settings

    The default profile form shortcode is in the user page:
    Shortcode

    On live preview in WPADMIN, all sections and all fields of the form shows up beautifully:
    Live Preview

    MEMBER FRONT END:

    On user page, when member logged in and viewing profile, only part of the form shows:
    Member Profile Page1

    Also, I can’t figure out where the edit icon is for members to edit the fields. There is an icon with a pencil, but it points to editing posts linkL

    http://domain.com/subdirectory/user/allanliv/?profiletab=posts

    Summary:

    I need to know:

    1. How to get all custom fields to show
    2. What a member must do to be able to edit profile on user page
    3. How to remove that option on users profile icons to edit posts, since we won’t be using wordpress website for posts at this time.

    Any help with this would be greatly appreciated.

    Thanks!

    • This topic was modified 2 years, 10 months ago by bizfundi.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi!

    I’ve managed to sort out No 1 and 2.

    FOR ANYONE ELSE HAVING THE SAME PROBLEM:

    Click here for solution – it was the redirection url I had to add in user roles:
    Multi Step Registrations

    I still need to know this:

    3. How to remove that option on users profile icons to edit posts

    If anyone could let me know that would be awesome.

    P.S. I will be deleting images off first message.

    Hi

    Found it.

    For anyone else with this question, you go to settings, appearance and profile menu. I just turned the whole menu off.

    This issue is resolved for me!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Frontend Profile: 1. Custom fields not showing 2. where to edit profile’ is closed to new replies.