Support » Plugin: WooCommerce EU VAT Assistant » Frontend error after plugin update

  • Resolved Dario Sinozic

    (@dsinozic)


    Hi,
    my website frontend is not working after the last update. Please advise!
    If I deactivate the plugin all works fine.
    PS. Happy New Year!

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • the error log shows: Call to undefined method MaxMind\Db\Reader::getWithPrefixLen()

    Now I’ve set “Default customer’s location” to “none” (in woocommerce options) and the frontend is working, but I’m not sure whether this is the right fix for this issue.

    Plugin Author Diego

    (@daigo75)

    It looks like WooCommerce is using a version of the MaxMind Geolocation library (which is the one used to read the GeoIP database) which is older than the one currently included in our framework.
    The library was updated at the beginning of December and got included automatically in the latest release. The new version of the library is backward-compatible (i.e. WooCommerce would be able to use it), but the old version is not forward-compatible (i.e. plugins that expect the new version can’t use the old one).

    What happens is that, when the geolocation feature of WooCommerce is enabled, it loads its own MaxMind Geolocation library first (the old version), then the EU VAT Assistant can’t run because it was built for the new one.

    It should be sufficient to go back to the old version of the library, so that it’s aligned with the WooCommerce one. I’m going to ask to prepare a new build with that version, and that should solve the issue. In the meantime, you can also downgrade the EU VAT Assistant by downloading the second to last version from here: https://wordpress.org/plugins/woocommerce-eu-vat-assistant/advanced/ . At the bottom of the page, you can find a selector to download version 1.12.1.191217, which still uses the previous version of the library,

    Plugin Author Diego

    (@daigo75)

    UPDATE
    The fix will consist in downgrading the MaxMind DB Reader library to version 1.4.1. The change be applied to AFC framework 2.0.12.200101, which will be included with EU VAT Assistant 1.12.3.200101.

    Thank you Diego!
    Problem solved with this update.
    Best wishes,
    Dario

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Frontend error after plugin update’ is closed to new replies.