Support » Theme: Smartline Lite » Front page text jumps with featured post slider

  • Resolved dneale123

    (@dneale123)


    I’ve been using Smartline Lite for my community website for about 3 years, and one small thing has always happened on the front page – the page text and slider navigation buttons are always momentarily offset downwards by about 300 pixels while the first slide is showing after loading the page, then jump up to the correct position and stay there. I’ve enabled lazy loading to improve page performance, but this makes the problem more obvious as the text stays offset for the duration of the first slide.

    A screen shot showing the gap caused by the offset during the first slide is at https://bell-tower.org.uk/bell-tower.offset2.PNG

    Inspecting the page shows that the height of the div #frontpage-slider is 450px for the first slide on my site and 291px thereafter. A quick but not 100% correct fix is to add the CSS #frontpage-slider {max-height: 291px;} – but this will not work at all screen resolutions (I’ve done this temporarily to improve things for desktop visitors). Any better solutions?

    TIA,

    David.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • dneale123

    (@dneale123)

    Additional information: I’m using a child theme to help the site load faster with my custom CSS. Going back to the parent theme, disabling all my CSS and deactivating all the plugins makes no difference.

    dneale123

    (@dneale123)

    I’m guessing everything works fine if you choose the maximum recommended height for the slider, but if you go for less (I use the suggested 350px) you get this jump. In the end I added the css #frontpage-slider {height: auto !important;} and this seems to work at all screen resolutions. There is still a slight momentary jump up as the slider appears to be rendered before the header (will see if I can find a way of making a placeholder for it perhaps, or delaying the slider loading) but otherwise it’s now fixed.

    Theme Author ThemeZee

    (@themezee)

    Hi there,

    Thanks for using Smartline.

    Yes, the slider works fine if you use the required image sizes for all slider images, so each slide has the same height. With different heights of each slider there will always be some jumps.

    Best,
    Thomas

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.