Support » Plugin: WP2Static » Front page missing

  • Resolved dogma00

    (@dogma00)


    Hi!

    Trying out WP2Static for the Finnish Towel Day site.

    Everything goes otherwise smoothly, but the front page of the site gets rendered as a 404 error page: https://pyyhepaiva.fi/

    It should be just a regular WP index page with ten most recent postings, no gimmicks.

    No idea what’s wrong. Any ideas, hints?

    I’m sure I’m missing something obvious here… 😛

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Leon Stafford

    (@leonstafford)

    Hi there,

    I’ve seen this on another site with version 6.3 and will troubleshoot it soon. Could you please give me as much info about the histing environment and WP setup as you can, ie:

    – active plugins and theme
    – hosting provider/OS
    – any additional security layers (ie, CloudFlare)
    – Permalinks structure/if you have a post or page as static homepage in WP, etc

    It’s happening in my fiancee’s site, so should be fixed soon, or I’m in trouble 😉

    Cheers,

    Leon

    Whoa, _that_ was fast. Impressed!

    The theme is Elegant Grunge with some small modifications in a child theme.

    WP version is 5.0.3.

    Active plugins:
    – Classic Editor 1.3
    – Classic Editor Addon 2.4.0
    – Cool Tag Cloud 2.08
    – PayPal Buy Now Button 1.7.2
    – WP Random Blog Description Versio 1.3
    – … and of course WP2Static 6.3

    The site is hosted at the local web hotel https://planeetta.net/

    It’s a LiteSpeed Web Server. About the server OS, I got this info with “cat /proc/version” in Terminal:

    Linux version 3.10.0-962.3.2.lve1.5.24.6.el7.x86_64 (mockbuild@buildfarm02.cloudlinux.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-28) (GCC) ) #1 SMP Tue Dec 4 03:50:32 EST 2018

    No additional security layers, AFAIK, except that .htaccess forces the pages load over HTTPS. Not that necessary anymore with a static site, I guess, but I haven’t changed that.

    Permalinks are just the article names. And they do work. For example:
    https://pyyhepaiva.fi/pyyhepaiva-turussa-2006/ (a regular article)
    https://pyyhepaiva.fi/category/paul-neil-milne-johnstone/ (category listing)
    https://pyyhepaiva.fi/tag/runosato-2017/ (tag listing)
    https://pyyhepaiva.fi/about/ (a page)

    So, all the pages seem to be there, including category and tag pages. Just the front page has escaped through a wormhole to some planet where it can live more frontpage-friendly life.

    Plugin Author Leon Stafford

    (@leonstafford)

    Hi @dogma00,

    Haha, my favourite comment, thus far!

    OK, I’ll keep digging on this and strange it’s just the homepage, else I’d recommend updating the WP site URL to be https, the plugin has had some issues when it’s forced via htaccess/wp-config, as it uses the WP site URLs in its rewriting rules.

    Will compare with my partner’s site and try to replicate than solve this.

    I’ve started work on a Debug Mode for the next release, which will help us in debugging these things, too.

    Cheers,

    Leon

    Plugin Author Leon Stafford

    (@leonstafford)

    In the meantime, in case you haven’t listened to:

    https://www.bbc.co.uk/programmes/p05w5bkx

    Ach, forgot to mention that https is forced only on the server, not locally where WP resides. And the local machine is running OS X 10.12.6.

    WP-config forces the local site to use address http://localhost/pyyhepaiva just so that the site shows up in the browser. Could that be the source of headache?

    These are the wp-config.php settings:
    define(‘WP_HOME’,’http://localhost/pyyhepaiva’);
    define(‘WP_SITEURL’,’http://localhost/pyyhepaiva’);

    Meanwhile, after I fixed the front page manually, I noticed that the static front page history didn’t go past /page/2/. Then I noticed that category history doesn’t go past page 2 either, and tags neither.

    But that was fixed by including all of them in the crawling text field.

    I also tried adding first / in the crawling text field, then /pyyhepaiva/ (which is the actual relative local address) and finally /index.php. The last one worked in a way: output was broken. Styles and images were missing. And the included file was index.php, but without php code, just with rendered html.

    Thanks for the Boring Talks link! Hadn’t heard of that one.

    • This reply was modified 2 months, 3 weeks ago by  dogma00.
    Plugin Author Leon Stafford

    (@leonstafford)

    Hi Dogma,

    Could you please test the build attached here if this solves your front page issue?

    https://github.com/leonstafford/wp2static/issues/276

    I’ve just loaded up the latest dev build on my partner’s site to start debugging and the issue seems to have solved itself by way of other recent updates.

    There is also a Debug Mode under the Advanced Menu, in case it isn’t fixed, could you please turn that on and re-run, then check the Export Log.

    I’ll have a fix in for paginated links soon, as per this one:

    https://github.com/leonstafford/wp2static/issues/275

    Cheers,

    Leon

    Plugin Author Leon Stafford

    (@leonstafford)

    Hi @dogma00,

    6.6 just released, in case the previous ones didn’t solve your issue.

    Please open a new issue in case errors are remaining and email me through another Debug Log.

    So long and thanks for all the fish,

    Leon

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.