"Front page displays" option disappears when deleting selected static page (5 posts)

  1. Visor57
    Posted 5 years ago #

    Hi there,

    while testing WP3.0 I set the "Front page displays" option under "Reading Settings" to display a static page. Subsequently I deleted the selected "static" page and was from then on unable to revert back to default option of displaying posts (the option is gone), and WP would display a "page cannot be found" error. Had to restore the static page from trash in order to gain access to option and revert to default post display.


  2. shutterbugsdesign
    Posted 5 years ago #

    I also noticed this. I have not created any page yet that's why the "Front page displays" won't appear.
    I then make one page then publish it. When I return to "Reading" the "Front page displays" is already there.

  3. esmi
    Forum Moderator
    Posted 5 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

  4. shutterbugsdesign
    Posted 5 years ago #

    here's a quick article, just like how I explained it before http://www.shutterbugsdesign.com/main/wordpress-front-page-displays-not-showing/

  5. mrmist
    Forum Janitor
    Posted 5 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic