Support » Plugin: Elementor Page Builder » Front page 500 error when try to edit with Elementor

  • Hi
    So I have been having an issue when trying to edit the front page content with Elementor I keep getting an internal server error, try to edit any other page and it works perfectly. I check the error log to see this, ModSecurity: Output filter: Response body too large (over limit of 524288, total not specified).

    I contacted my hosting with the information and after a few emails back and forward and fresh install of WordPress with just Elementor installed to test, they replied with this:

    Modsecurity is configured such that any page whose maximum response body size is above 512Kb will be rejected with a 500 internal server error.
    The plugin you are using is creating very long responses making it impossible for ModSecurity to analyse the responses.
    I had to put ModSecurity in detection only mode for your subdomain to get the plugin working.

    Please note that I was able to get the plugin working with ModSecurity on a very high SecResponseBodyLimit value. But this is not advisable as it will slow down your website performance because of high RAM usage by your account.

    Has anyone encountered this issue before? Any recommendations I could take back to my hosting to try would be awesome.

    Cheers,

Viewing 4 replies - 1 through 4 (of 4 total)
  • Yes, i’m having the same problem. I’ve extented the WP_MEMORY_LIMIT to the max and still getting the ModSecurity error.
    The host’ response was: try an other plugin…

    I’m glad I’m not the only one with this issue, I was hoping one of the developers could give some feedback so I could take it back to the web host.

    Plugin Author ArielK

    (@arielk-1)

    We are working hard to make Elementor as lightweight and fast loading as possible. Editing a page with Elementor on the frontend still involves a lot of data loading, especially with content rich homepages. Until now there have only been a few instances of such issues with hosting companies. Where are you hosting your site?

    Hey Arielk, Thanks for your reply.

    The hosting company I’m using is http://openhost.co.nz

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Front page 500 error when try to edit with Elementor’ is closed to new replies.